This is a first draft. If you have any questions or requests concerning the SDK or the documentation, please send them to info@ThePhysicsEngine.com.

nV Physics SDK
This is a first draft. If you have any questions or requests concerning the SDK or the documentation, please send them to info@ThePhysicsEngine.com.
Made with Doc-O-Matic.
Send comments on this topic.
Copyright (c) 2006. All rights reserved.


Classes

See Also
Classes
Classes

The following table lists classes in this documentation.

Classes
nvBody | The class representing a physical body, each nvBody is composed of one or more nvPrimitive (s)
nvBodyMngr | nvBodyMngr is the class responsible create and destroy physics bodies (nvBody). Each nvPhysicsWorld has an instance of nvBodyMngr.
nvBoxShape | Class used to hold box shape data.
nvCarWheelJoint | Car wheel joint with steering angle and suspension.
nvConvexShape | Class used to hold convex shape data.
nvCylinderShape | Class used to hold cylinder shape data.
nvDoubleHingeJoint | Double-hinge joint (hinge2)
nvHingeJoint | Hinge Joint
nvJoint | Base class for joints (constraints).
nvJointMngr | nvJointMngr is the class responsible create and destroy nvJoints (constraints). Each nvPhysicsWorld has an instance of nvJointMngr.
nvLimitedBallJoint | Ball joint with limits and motors on all axis.
nvPhysicsWorld | The physics world. The only object the user should instantiate manually. The root of the physics system.
nvPlaneShape | Class used to hold plane shape data
nvPrimitive | Class used to represent primitives. Each primitve has a shape, and is a part of one body.
nvShape | Base class for shape representation classes.
nvShapeMngr | The class responsible for creating and managing shapes (geometrical setups).
nvSphereShape | Class used to hold sphere shape data, needs cleanup?!
nvTriMeshShape | The shape class representing a STATIC triangle mesh.
See Also
Classes
Made with Doc-O-Matic.
Send comments on this topic.


nvBody Class

Classes | Members | Topics | Class Hierarchy | nvBody Data Members | nvBody Methods | nvBody Members | nvBody Data Members | nvBody Methods
nV Physics SDK
nvBody Class
nvBody
C++
public: class nvBody;
File

Body.h

Remarks

The class representing a physical body, each nvBody is composed of one or more nvPrimitive (s)

Topics
nvBody Members | The following tables list the members exposed by nvBody.
nvBody Data Members | The data members of the nvBody class are listed here.
nvBody Methods | The methods of the nvBody class are listed here.
nvBody Data Members
Primitives
List of primitives contained in the body.
nvBody Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.
See Also
Classes | Members | Topics | Class Hierarchy | nvBody Data Members | nvBody Methods | nvBody Members | nvBody Data Members | nvBody Methods


nvBody Members

nvBody Class | Public Data Members | Public Methods
nvBody Members

The following tables list the members exposed by nvBody.

Public Data Members
Primitives
List of primitives contained in the body.
Public Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.
See Also
nvBody Class | Public Data Members | Public Methods


nvBody Data Members

nvBody Class | Public Data Members
nvBody Data Members

The data members of the nvBody class are listed here.

Public Data Members
Primitives
List of primitives contained in the body.
See Also
nvBody Class | Public Data Members


nvBody::Primitives Data Member

nvBody Data Members | nvBody Class | nvBody Members
nvBody::Primitives Data Member
C++
public: std::vector<nvPrimitive*> Primitives;
Remarks

List of primitives contained in the body.

See Also
nvBody Data Members | nvBody Class | nvBody Members


nvBody Methods

nvBody Class | Public Methods
nvBody Methods

The methods of the nvBody class are listed here.

Public Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.
See Also
nvBody Class | Public Methods


nvBody::AddBox Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddBox Method
C++
public: nvPrimitive* AddBox(
    nvReal mass,
    nvReal xLength,
    nvReal yLength,
    nvReal zLength
);
Remarks

Adds a box primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::AddConvex Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddConvex Method
C++
public: nvPrimitive* AddConvex(
    nvReal mass
);
Remarks

Adds a convex primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::AddCylinder Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddCylinder Method
C++
public: nvPrimitive* AddCylinder(
    nvReal mass,
    nvReal radius,
    nvReal height
);
Remarks

Adds a cylinder primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::AddNewPrimitive Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddNewPrimitive Method
C++
public: nvPrimitive* AddNewPrimitive(
    nvShape* pShape,
    nvReal mass,
    nvReal* pWorldPosition = 0,
    nvReal* pWorldRotation = 0
);
Parameters
Parameters | Description
pWorldPosition | World position (three consecutive real numbers).
pWorldRotation | World rotation 3x3 matrix of real numbers.
Remarks

Adds a primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


AddOneFrameForce Method

nvBody Methods
AddOneFrameForce Method
Overload List
nvBody::AddOneFrameForce (nvReal, nvReal, nvReal) | Applies a force on the body for the duration of the next time step. (unit: newton)
nvBody::AddOneFrameForce (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal) | Applies a force on the body, that acts on a specified point for the duration of the next time step. (unit: newton)
See Also
nvBody Methods


nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal)

AddOneFrameForce Method | nvBody Class | nvBody Members
nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal)
C++
public: void AddOneFrameForce(
    nvReal xForceOnCenterOfMass,
    nvReal yForceOnCenterOfMass,
    nvReal zForceOnCenterOfMass
);
Remarks

Applies a force on the body for the duration of the next time step. (unit: newton)

See Also
AddOneFrameForce Method | nvBody Class | nvBody Members


nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)

AddOneFrameForce Method | nvBody Class | nvBody Members
nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
C++
public: void AddOneFrameForce(
    nvReal xBodySpaceForce,
    nvReal yBodySpaceForce,
    nvReal zBodySpaceForce,
    nvReal xBodySpacePointOfAct,
    nvReal yBodySpacePointOfAct,
    nvReal zBodySpacePointOfAct
);
Remarks

Applies a force on the body, that acts on a specified point for the duration of the next time step. (unit: newton)

See Also
AddOneFrameForce Method | nvBody Class | nvBody Members


nvBody::AddOneFrameTorque Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddOneFrameTorque Method
C++
public: void AddOneFrameTorque(
    nvReal xTorque,
    nvReal yTorque,
    nvReal zTorque
);
Remarks

Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.

See Also
nvBody Methods | nvBody Class | nvBody Members


AddPermanentForce Method

nvBody Methods
AddPermanentForce Method
Overload List
nvBody::AddPermanentForce (nvReal, nvReal, nvReal) | Adds a permenant force on the body, specified as a vector. (unit: newton)
nvBody::AddPermanentForce (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal) | Adds a permenant force on the body, that acts on a specified point. (unit: newton)
See Also
nvBody Methods


nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal)

AddPermanentForce Method | nvBody Class | nvBody Members
nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal)
C++
public: void AddPermanentForce(
    nvReal xForceOnCenterOfMass,
    nvReal yForceOnCenterOfMass,
    nvReal zForceOnCenterOfMass
);
Remarks

Adds a permenant force on the body, specified as a vector. (unit: newton)

See Also
AddPermanentForce Method | nvBody Class | nvBody Members


nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)

AddPermanentForce Method | nvBody Class | nvBody Members
nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
C++
public: void AddPermanentForce(
    nvReal xBodySpaceForce,
    nvReal yBodySpaceForce,
    nvReal zBodySpaceForce,
    nvReal xBodySpacePointOfAct,
    nvReal yBodySpacePointOfAct,
    nvReal zBodySpacePointOfAct
);
Parameters
Parameters | Description
xBodySpacePointOfAct | X coordinate of the point on which the force is applied. (given in body space)
yBodySpacePointOfAct | Y coordinate of the point on which the force is applied. (given in body space)
zBodySpacePointOfAct | Z coordinate of the point on which the force is applied. (given in body space)
Remarks

Adds a permenant force on the body, that acts on a specified point. (unit: newton)

See Also
AddPermanentForce Method | nvBody Class | nvBody Members


nvBody::AddPermanentTorque Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddPermanentTorque Method
C++
public: void AddPermanentTorque(
    nvReal xTorque,
    nvReal yTorque,
    nvReal zTorque
);
Remarks

Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.

See Also
nvBody Methods | nvBody Class | nvBody Members


AddPlane Method

nvBody Methods
AddPlane Method
Overload List
nvBody::AddPlane (nvReal, nvReal, nvReal, nvReal) | Adds a plane primitive to the body using a point and a constant.
nvBody::AddPlane (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal) | Adds a plane primitive to the body using a point and a normal.
See Also
nvBody Methods


nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal)

AddPlane Method | nvBody Class | nvBody Members
nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal)
C++
public: nvPrimitive* AddPlane(
    nvReal nx,
    nvReal ny,
    nvReal nz,
    nvReal d
);
Remarks

Adds a plane primitive to the body using a point and a constant.

See Also
AddPlane Method | nvBody Class | nvBody Members


nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)

AddPlane Method | nvBody Class | nvBody Members
nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
C++
public: nvPrimitive* AddPlane(
    nvReal xPointOnPlane,
    nvReal yPointOnPlane,
    nvReal zPointOnPlane,
    nvReal xNormalOnPlane,
    nvReal yNormalOnPlane,
    nvReal zNormalOnPlane
);
Remarks

Adds a plane primitive to the body using a point and a normal.

See Also
AddPlane Method | nvBody Class | nvBody Members


nvBody::AddSphere Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddSphere Method
C++
public: nvPrimitive* AddSphere(
    nvReal mass,
    nvReal radius
);
Remarks

Adds a sphere primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::AddTriMesh Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::AddTriMesh Method
C++
public: nvPrimitive* AddTriMesh(
    nvReal mass
);
Remarks

Adds a triangle mesh primitive to the body.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetAngularVelocity Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetAngularVelocity Method
C++
public: void GetAngularVelocity(
    nvReal & xAngularVelocity,
    nvReal & yAngularVelocity,
    nvReal & zAngularVelocity
);
Remarks

Returns angular velocity of the body. (expressed as a vector in radians per second)

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetCenterOfMass Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetCenterOfMass Method
C++
public: void GetCenterOfMass(
    nvReal & xWorldCenterOfMass,
    nvReal & yWorldCenterOfMass,
    nvReal & zWorldCenterOfMass
);
Remarks

Returns the center of mass for the body at hand.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetData Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetData Method
C++
public: void* GetData();
Remarks

Gets the user defined data associated with the body if any.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetLinearVelocity Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetLinearVelocity Method
C++
public: void GetLinearVelocity(
    nvReal & xLinearVelocity,
    nvReal & yLinearVelocity,
    nvReal & zLinearVelocity
);
Remarks

Returns linear velocity of the body. (expressed as a vector in meters per second)

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetMass Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetMass Method
C++
public: nvReal GetMass();
Remarks

Returns the body's mass in kilograms.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetPositon Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetPositon Method
C++
public: void GetPositon(
    nvReal & xWorldPosition,
    nvReal & yWorldPosition,
    nvReal & zWorldPosition
);
Remarks

Returns the body's world coordinates.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::GetRotationMatrix Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::GetRotationMatrix Method
C++
public: nvReal* GetRotationMatrix();
Remarks

Returns a 3x3 rotation matrix.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::IsSleeping Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::IsSleeping Method
C++
public: bool IsSleeping();
Remarks

Indicates whether the body is deactivated.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::IsStatic Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::IsStatic Method
C++
public: bool IsStatic();
Remarks

Indicates whether the body is static (not controlled by physics).

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::Move Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::Move Method
C++
public: void Move(
    nvReal deltaX,
    nvReal deltaY,
    nvReal deltaZ
);
Remarks

Instantaniously moves the body to the specified world coordinates.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::RotateAxisAngle Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::RotateAxisAngle Method
C++
public: void RotateAxisAngle(
    nvReal xAxis,
    nvReal yAxis,
    nvReal zAxis,
    nvReal angle
);
Remarks

Rotates a body about a specified axis with a specified angle.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::SetAngularVelocity Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::SetAngularVelocity Method
C++
public: void SetAngularVelocity(
    nvReal xAngularVelocity,
    nvReal yAngularVelocity,
    nvReal zAngularVelocity
);
Remarks

Sets the angular velocity for the body. (expressed as a vector in radians per second)

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::SetData Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::SetData Method
C++
public: void SetData(
    void* pUserData
);
Remarks

Associates the body data structure with any user defined data.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::SetLinearVelocity Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::SetLinearVelocity Method
C++
public: void SetLinearVelocity(
    nvReal xLinearVelocity,
    nvReal yLinearVelocity,
    nvReal zLinearVelocity
);
Remarks

Sets the linear velocity for the body. (expressed as a vector in meters per second)

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBody::SetPosition Method

nvBody Methods | nvBody Class | nvBody Members
nvBody::SetPosition Method
C++
public: void SetPosition(
    nvReal xWorldPosition,
    nvReal yWorldPosition,
    nvReal zWorldPosition
);
Remarks

Sets the body's world coordinates.

See Also
nvBody Methods | nvBody Class | nvBody Members


nvBodyMngr Class

Classes | Members | Topics | Class Hierarchy | nvBodyMngr Methods | nvBodyMngr Members | nvBodyMngr Methods
nV Physics SDK
nvBodyMngr Class
nvBodyMngr
C++
public: class nvBodyMngr;
File

BodyMngr.h

Remarks

nvBodyMngr is the class responsible create and destroy physics bodies (nvBody). Each nvPhysicsWorld has an instance of nvBodyMngr.

Topics
nvBodyMngr Members | The following tables list the members exposed by nvBodyMngr.
nvBodyMngr Methods | The methods of the nvBodyMngr class are listed here.
nvBodyMngr Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.
See Also
Classes | Members | Topics | Class Hierarchy | nvBodyMngr Methods | nvBodyMngr Members | nvBodyMngr Methods


nvBodyMngr Members

nvBodyMngr Class | Public Methods
nvBodyMngr Members

The following tables list the members exposed by nvBodyMngr.

Public Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.
See Also
nvBodyMngr Class | Public Methods


nvBodyMngr Methods

nvBodyMngr Class | Public Methods
nvBodyMngr Methods

The methods of the nvBodyMngr class are listed here.

Public Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.
See Also
nvBodyMngr Class | Public Methods


nvBodyMngr::Create Method

nvBodyMngr Methods | nvBodyMngr Class | nvBodyMngr Members
nvBodyMngr::Create Method
C++
public: nvBody* Create();
Remarks

Simply creates a new physics body.

See Also
nvBodyMngr Methods | nvBodyMngr Class | nvBodyMngr Members


nvBodyMngr::Destroy Method

nvBodyMngr Methods | nvBodyMngr Class | nvBodyMngr Members
nvBodyMngr::Destroy Method
C++
public: void Destroy(
    nvBody* pBody
);
Remarks

Similarly destroys the body.

See Also
nvBodyMngr Methods | nvBodyMngr Class | nvBodyMngr Members


nvBoxShape Class

Classes | Members | Topics | Class Hierarchy | nvBoxShape Methods | nvBoxShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvBoxShape Class
nvShape
    nvBoxShape
C++
public: class nvBoxShape : public nvShape;
File

BoxShape.h

Remarks

Class used to hold box shape data.

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvBoxShape Class
nvBoxShape Members | The following tables list the members exposed by nvBoxShape.
nvBoxShape Methods | The methods of the nvBoxShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvBoxShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvBoxShape Methods | nvBoxShape Members | nvShape Enumerations | nvShape Methods


nvBoxShape Members

Enumerations | nvBoxShape Class | Public Methods
nvBoxShape Members

The following tables list the members exposed by nvBoxShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvBoxShape Class | Public Methods


nvBoxShape Methods

nvBoxShape Class | Public Methods
nvBoxShape Methods

The methods of the nvBoxShape class are listed here.

Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvBoxShape Class | Public Methods


nvBoxShape::GetBoundingRadius Method

nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members
nvBoxShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members


nvBoxShape::GetBoundingRadiusSqr Method

nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members
nvBoxShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere.

See Also
nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members


nvBoxShape::GetDimensions Method

nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members
nvBoxShape::GetDimensions Method
C++
public: void GetDimensions(
    nvReal & x,
    nvReal & y,
    nvReal & z
);
Remarks

Returns the three dimentions of the box shape.

See Also
nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members


nvBoxShape::GetType Method

nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members
nvBoxShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvBoxShape Methods | nvBoxShape Class | nvBoxShape Members


nvCarWheelJoint Class

Classes | Members | Topics | Class Hierarchy | nvCarWheelJoint Methods | nvCarWheelJoint Members | nvCarWheelJoint Methods
nV Physics SDK
nvCarWheelJoint Class
nvJoint
    nvCarWheelJoint
C++
public: class nvCarWheelJoint : public nvJoint;
File

Joint.h

Remarks

Car wheel joint with steering angle and suspension.

Topics
nvCarWheelJoint Class
nvCarWheelJoint Members | The following tables list the members exposed by nvCarWheelJoint.
nvCarWheelJoint Methods | The methods of the nvCarWheelJoint class are listed here.
nvCarWheelJoint Methods
nvCarWheelJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.
See Also
Classes | Members | Topics | Class Hierarchy | nvCarWheelJoint Methods | nvCarWheelJoint Members | nvCarWheelJoint Methods


nvCarWheelJoint Members

nvCarWheelJoint Class | Public Methods
nvCarWheelJoint Members

The following tables list the members exposed by nvCarWheelJoint.

Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.
See Also
nvCarWheelJoint Class | Public Methods


nvCarWheelJoint Methods

nvCarWheelJoint Class | Public Methods
nvCarWheelJoint Methods

The methods of the nvCarWheelJoint class are listed here.

Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.
See Also
nvCarWheelJoint Class | Public Methods


nvCarWheelJoint::AddOneFrameTorque Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::AddOneFrameTorque Method
C++
public: void AddOneFrameTorque(
    float Torque
);
Remarks

Adds a torque to the joint that affects the bodies connected for the next time step.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvCarWheelJoint::GetAngle Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::GetAngle Method
C++
public: float GetAngle();
Remarks

Returns the current angle of the joint.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvCarWheelJoint::GetVelocity Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::GetVelocity Method
C++
public: float GetVelocity();
Remarks

Returns the angular velocity with which the joint moves.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvCarWheelJoint::SetMaxTorque Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::SetMaxTorque Method
C++
public: void SetMaxTorque(
    float MaxTorque
);
Remarks

Sets the maximum torque with which the joint can affect the bodies concerned.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvCarWheelJoint::SetRequiredVelocity Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::SetRequiredVelocity Method
C++
public: void SetRequiredVelocity(
    float vel
);
Remarks

Sets the required angular velocity for the joint in radians per second.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvCarWheelJoint::SetSteeringAngle Method

nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members
nV Physics SDK
nvCarWheelJoint::SetSteeringAngle Method
C++
public: void SetSteeringAngle(
    float Angle
);
Remarks

Sets the steering angle of the wheel.

See Also
nvCarWheelJoint Methods | nvCarWheelJoint Class | nvCarWheelJoint Members


nvConvexShape Class

Classes | Members | Topics | Class Hierarchy | nvConvexShape Methods | nvConvexShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvConvexShape Class
nvShape
    nvConvexShape
C++
public: class nvConvexShape : public nvShape;
File

ConvexShape.h

Remarks

Class used to hold convex shape data.

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvConvexShape Class
nvConvexShape Members | The following tables list the members exposed by nvConvexShape.
nvConvexShape Methods | The methods of the nvConvexShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvConvexShape Class
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvConvexShape Methods | nvConvexShape Members | nvShape Enumerations | nvShape Methods


nvConvexShape Members

Enumerations | nvConvexShape Class | Public Methods
nvConvexShape Members

The following tables list the members exposed by nvConvexShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvConvexShape Class | Public Methods


nvConvexShape Methods

nvConvexShape Class | Public Methods
nvConvexShape Methods

The methods of the nvConvexShape class are listed here.

Public Methods
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvConvexShape Class | Public Methods


nvConvexShape::AddEdge Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddEdge Method
C++
public: void AddEdge(
    nvReal* pVertexA,
    nvReal* pVertexB
);
Remarks

Adds a new edge, by putting 2 vertices, and one edge.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddIndexedTriangleFan Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddIndexedTriangleFan Method
C++
public: void AddIndexedTriangleFan(
    void* pStartVertex,
    int stride,
    int vertexCount
);
Remarks

adds an indexed triangle fan.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddIndexedTriangles Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddIndexedTriangles Method
C++
public: void AddIndexedTriangles(
    void* pStartVertex,
    int* pIndices,
    int stride,
    int indexCount
);
Remarks

Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddIndexedTriangleStrip Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddIndexedTriangleStrip Method
C++
public: void AddIndexedTriangleStrip(
    void* pStartVertex,
    int* pIndices,
    int stride,
    int indexCount
);
Remarks

Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddTriangle Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddTriangle Method
C++
public: void AddTriangle(
    nvReal* pVertexA,
    nvReal* pVertexB,
    nvReal* pVertexC
);
Remarks

Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddTriangleFan Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddTriangleFan Method
C++
public: void AddTriangleFan(
    void* pStartVertex,
    int stride,
    int vertexCount
);
Remarks

Adds a triangle fan.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddTriangles Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddTriangles Method
C++
public: void AddTriangles(
    void* pStartVertex,
    int stride,
    int numVerts
);
Remarks

Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddTriangleStrip Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddTriangleStrip Method
C++
public: void AddTriangleStrip(
    void* pStartVertex,
    int stride,
    int vertexCount
);
Remarks

Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::AddVertices Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::AddVertices Method
C++
public: void AddVertices(
    void* pStartVertex,
    int stride,
    int vertexCount
);
Remarks

A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::Begin Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::Begin Method
C++
public: void Begin();
Remarks

these 2 function calls are essential vertices should only be added between a begin and an end

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::End Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::End Method
C++
public: void End();
Remarks

call this when done with adding vertices

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::GetBoundingRadius Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::GetBoundingRadiusSqr Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvConvexShape::GetType Method

nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members
nV Physics SDK
nvConvexShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvConvexShape Methods | nvConvexShape Class | nvConvexShape Members


nvCylinderShape Class

Classes | Members | Topics | Class Hierarchy | nvCylinderShape Methods | nvCylinderShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvCylinderShape Class
nvShape
    nvCylinderShape
C++
public: class nvCylinderShape : public nvShape;
File

CylinderShape.h

Remarks

Class used to hold cylinder shape data.

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvCylinderShape Class
nvCylinderShape Members | The following tables list the members exposed by nvCylinderShape.
nvCylinderShape Methods | The methods of the nvCylinderShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvCylinderShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvCylinderShape Methods | nvCylinderShape Members | nvShape Enumerations | nvShape Methods


nvCylinderShape Members

Enumerations | nvCylinderShape Class | Public Methods
nvCylinderShape Members

The following tables list the members exposed by nvCylinderShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvCylinderShape Class | Public Methods


nvCylinderShape Methods

nvCylinderShape Class | Public Methods
nvCylinderShape Methods

The methods of the nvCylinderShape class are listed here.

Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvCylinderShape Class | Public Methods


nvCylinderShape::GetBoundingRadius Method

nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members
nV Physics SDK
nvCylinderShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members


nvCylinderShape::GetBoundingRadiusSqr Method

nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members
nV Physics SDK
nvCylinderShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere.

See Also
nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members


nvCylinderShape::GetHeight Method

nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members
nV Physics SDK
nvCylinderShape::GetHeight Method
C++
public: nvReal GetHeight();
Remarks

Returns the height of the cylinder.

See Also
nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members


nvCylinderShape::GetRadius Method

nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members
nV Physics SDK
nvCylinderShape::GetRadius Method
C++
public: nvReal GetRadius();
Remarks

Returns radius of the cylinder.

See Also
nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members


nvCylinderShape::GetType Method

nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members
nV Physics SDK
nvCylinderShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvCylinderShape Methods | nvCylinderShape Class | nvCylinderShape Members


nvDoubleHingeJoint Class

Classes | Members | Topics | Class Hierarchy | nvDoubleHingeJoint Methods | nvDoubleHingeJoint Members | nvDoubleHingeJoint Methods
nV Physics SDK
nvDoubleHingeJoint Class
nvJoint
    nvDoubleHingeJoint
C++
public: class nvDoubleHingeJoint : public nvJoint;
File

Joint.h

Remarks

Double-hinge joint (hinge2)

Topics
nvDoubleHingeJoint Class
nvDoubleHingeJoint Members | The following tables list the members exposed by nvDoubleHingeJoint.
nvDoubleHingeJoint Methods | The methods of the nvDoubleHingeJoint class are listed here.
nvDoubleHingeJoint Methods
nvDoubleHingeJoint Class
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.
See Also
Classes | Members | Topics | Class Hierarchy | nvDoubleHingeJoint Methods | nvDoubleHingeJoint Members | nvDoubleHingeJoint Methods


nvDoubleHingeJoint Members

nvDoubleHingeJoint Class | Public Methods
nvDoubleHingeJoint Members

The following tables list the members exposed by nvDoubleHingeJoint.

Public Methods
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.
See Also
nvDoubleHingeJoint Class | Public Methods


nvDoubleHingeJoint Methods

nvDoubleHingeJoint Class | Public Methods
nvDoubleHingeJoint Methods

The methods of the nvDoubleHingeJoint class are listed here.

Public Methods
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.
See Also
nvDoubleHingeJoint Class | Public Methods


nvDoubleHingeJoint::AddOneFrameTorque1 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::AddOneFrameTorque1 Method
C++
public: void AddOneFrameTorque1(
    float Torque
);
Remarks

Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvDoubleHingeJoint::AddOneFrameTorque2 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::AddOneFrameTorque2 Method
C++
public: void AddOneFrameTorque2(
    float Torque
);
Remarks

Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvDoubleHingeJoint::SetMaxTorque1 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::SetMaxTorque1 Method
C++
public: void SetMaxTorque1(
    float MaxTorque
);
Remarks

Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvDoubleHingeJoint::SetMaxTorque2 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::SetMaxTorque2 Method
C++
public: void SetMaxTorque2(
    float MaxTorque
);
Remarks

Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvDoubleHingeJoint::SetRequiredVelocity1 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::SetRequiredVelocity1 Method
C++
public: void SetRequiredVelocity1(
    float vel
);
Remarks

Sets the required angular velocity about axis-1 for the joint in radians per second.

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvDoubleHingeJoint::SetRequiredVelocity2 Method

nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members
nV Physics SDK
nvDoubleHingeJoint::SetRequiredVelocity2 Method
C++
public: void SetRequiredVelocity2(
    float vel
);
Remarks

Sets the required angular velocity about axis-2 for the joint in radians per second.

See Also
nvDoubleHingeJoint Methods | nvDoubleHingeJoint Class | nvDoubleHingeJoint Members


nvHingeJoint Class

Classes | Members | Topics | Class Hierarchy | nvHingeJoint Methods | nvHingeJoint Members | nvHingeJoint Methods
nV Physics SDK
nvHingeJoint Class
nvJoint
    nvHingeJoint
C++
public: class nvHingeJoint : public nvJoint;
File

Joint.h

Remarks

Hinge Joint

Topics
nvHingeJoint Class
nvHingeJoint Members | The following tables list the members exposed by nvHingeJoint.
nvHingeJoint Methods | The methods of the nvHingeJoint class are listed here.
nvHingeJoint Methods
nvHingeJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
See Also
Classes | Members | Topics | Class Hierarchy | nvHingeJoint Methods | nvHingeJoint Members | nvHingeJoint Methods


nvHingeJoint Members

nvHingeJoint Class | Public Methods
nvHingeJoint Members

The following tables list the members exposed by nvHingeJoint.

Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
See Also
nvHingeJoint Class | Public Methods


nvHingeJoint Methods

nvHingeJoint Class | Public Methods
nvHingeJoint Methods

The methods of the nvHingeJoint class are listed here.

Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
See Also
nvHingeJoint Class | Public Methods


nvHingeJoint::AddOneFrameTorque Method

nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members
nV Physics SDK
nvHingeJoint::AddOneFrameTorque Method
C++
public: void AddOneFrameTorque(
    float Torque
);
Remarks

Adds a torque to the joint that affects the bodies connected for the next time step.

See Also
nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members


nvHingeJoint::GetAngle Method

nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members
nV Physics SDK
nvHingeJoint::GetAngle Method
C++
public: nvReal GetAngle();
Remarks

Returns the current angle of the joint.

See Also
nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members


nvHingeJoint::GetVelocity Method

nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members
nV Physics SDK
nvHingeJoint::GetVelocity Method
C++
public: nvReal GetVelocity();
Remarks

Returns the angular velocity with which the joint moves. (unit: radians per second)

See Also
nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members


nvHingeJoint::SetMaxTorque Method

nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members
nV Physics SDK
nvHingeJoint::SetMaxTorque Method
C++
public: void SetMaxTorque(
    float MaxTorque
);
Remarks

Sets the maximum torque with which the joint can affect the bodies concerned.

See Also
nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members


nvHingeJoint::SetRequiredVelocity Method

nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members
nV Physics SDK
nvHingeJoint::SetRequiredVelocity Method
C++
public: void SetRequiredVelocity(
    float AngularVelocity
);
Remarks

Sets the required angular velocity for the joint in radians per second.

See Also
nvHingeJoint Methods | nvHingeJoint Class | nvHingeJoint Members


nvJoint Class

Classes | Class Hierarchy
nvJoint Class
nvJoint
    nvCarWheelJoint
    nvDoubleHingeJoint
    nvHingeJoint
    nvLimitedBallJoint
C++
public: class nvJoint;
File

Joint.h

Remarks

Base class for joints (constraints).

See Also
Classes | Class Hierarchy


nvJointMngr Class

Classes | Members | Topics | Class Hierarchy | nvJointMngr Methods | nvJointMngr Members | nvJointMngr Methods
nV Physics SDK
nvJointMngr Class
nvJointMngr
C++
public: class nvJointMngr;
File

JointMngr.h

Remarks

nvJointMngr is the class responsible create and destroy nvJoints (constraints). Each nvPhysicsWorld has an instance of nvJointMngr.

Topics
nvJointMngr Members | The following tables list the members exposed by nvJointMngr.
nvJointMngr Methods | The methods of the nvJointMngr class are listed here.
nvJointMngr Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.
See Also
Classes | Members | Topics | Class Hierarchy | nvJointMngr Methods | nvJointMngr Members | nvJointMngr Methods


nvJointMngr Members

nvJointMngr Class | Public Methods
nvJointMngr Members

The following tables list the members exposed by nvJointMngr.

Public Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.
See Also
nvJointMngr Class | Public Methods


nvJointMngr Methods

nvJointMngr Class | Public Methods
nvJointMngr Methods

The methods of the nvJointMngr class are listed here.

Public Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.
See Also
nvJointMngr Class | Public Methods


CreateBallJoint Method

nvJointMngr Methods
CreateBallJoint Method
Overload List
nvJointMngr::CreateBallJoint (nvBody *, nvBody *, nvReal, nvReal, nvReal) | Creates a ball joint (ball-socket, point to point) given the two bodies and the anchor.
nvJointMngr::CreateBallJoint (nvBody *, nvReal, nvReal, nvReal, nvBody *, nvReal, nvReal, nvReal) | Creates a ball joint (ball-socket, point to point) given the two bodies and the anchor point. The Anchor point is specified twice relative to each body respectively.
See Also
nvJointMngr Methods


nvJointMngr::CreateBallJoint Method (nvBody *, nvBody *, nvReal, nvReal, nvReal)

CreateBallJoint Method | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateBallJoint Method (nvBody *, nvBody *, nvReal, nvReal, nvReal)
C++
public: nvJoint* CreateBallJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint
);
Remarks

Creates a ball joint (ball-socket, point to point) given the two bodies and the anchor.

See Also
CreateBallJoint Method | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateBallJoint Method (nvBody *, nvReal, nvReal, nvReal, nvBody *, nvReal, nvReal, nvReal)

CreateBallJoint Method | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateBallJoint Method (nvBody *, nvReal, nvReal, nvReal, nvBody *, nvReal, nvReal, nvReal)
C++
public: nvJoint* CreateBallJoint(
    nvBody * pBdy1,
    nvReal r1x,
    nvReal r1y,
    nvReal r1z,
    nvBody * pBdy2,
    nvReal r2x,
    nvReal r2y,
    nvReal r2z
);
Remarks

Creates a ball joint (ball-socket, point to point) given the two bodies and the anchor point. The Anchor point is specified twice relative to each body respectively.

See Also
CreateBallJoint Method | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateCarWheelJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateCarWheelJoint Method
C++
public: nvJoint* CreateCarWheelJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis,
    nvReal yAxis,
    nvReal zAxis,
    nvReal xSteeringAxis,
    nvReal ySteeringAxis,
    nvReal zSteeringAxis,
    nvReal Stiffness = 100.0f
);
Remarks

Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateDoubleHingeJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateDoubleHingeJoint Method
C++
public: nvJoint* CreateDoubleHingeJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis1,
    nvReal yAxis1,
    nvReal zAxis1,
    nvReal xAxis2,
    nvReal yAxis2,
    nvReal zAxis2
);
Remarks

Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateFixedJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateFixedJoint Method
C++
public: nvJoint* CreateFixedJoint(
    nvBody* pBdy1,
    nvBody* pBdy2
);
Remarks

Creates a fixed joint between two given bodies.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateHingeJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateHingeJoint Method
C++
public: nvJoint* CreateHingeJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis,
    nvReal yAxis,
    nvReal zAxis
);
Remarks

Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateLimitedBallJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateLimitedBallJoint Method
C++
public: nvJoint* CreateLimitedBallJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis1,
    nvReal yAxis1,
    nvReal zAxis1,
    nvReal xAxis2,
    nvReal yAxis2,
    nvReal zAxis2
);
Remarks

Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateStiffSpringJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateStiffSpringJoint Method
C++
public: nvJoint* CreateStiffSpringJoint(
    nvBody* pBdy1,
    nvReal xR1,
    nvReal yR1,
    nvReal zR1,
    nvBody* pBdy2,
    nvReal xR2,
    nvReal yR2,
    nvReal zR2,
    nvReal L,
    nvReal Stiffness = 1.0f,
    nvReal Dampenning = 0.9f
);
Remarks

Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::CreateUniversalJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::CreateUniversalJoint Method
C++
public: nvJoint* CreateUniversalJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis1,
    nvReal yAxis1,
    nvReal zAxis1,
    nvReal xAxis2,
    nvReal yAxis2,
    nvReal zAxis2
);
Remarks

Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::DeleteAllBodyJoints Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::DeleteAllBodyJoints Method
C++
public: void DeleteAllBodyJoints(
    nvBody* pBody
);
Remarks

destroys all joints attached to the specified body. (Useless to expose?)

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::DestroyJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::DestroyJoint Method
C++
public: void DestroyJoint(
    nvJoint* pJ
);
Remarks

Destroys a given joint.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvJointMngr::nvJointMngr::CreatePrismaticJoint Method

nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members
nV Physics SDK
nvJointMngr::nvJointMngr::CreatePrismaticJoint Method
C++
public: nvJoint* nvJointMngr::CreatePrismaticJoint(
    nvBody * pBdy1,
    nvBody * pBdy2,
    nvReal xGlobalPoint,
    nvReal yGlobalPoint,
    nvReal zGlobalPoint,
    nvReal xAxis,
    nvReal yAxis,
    nvReal zAxis
);
Remarks

Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.

See Also
nvJointMngr Methods | nvJointMngr Class | nvJointMngr Members


nvLimitedBallJoint Class

Classes | Members | Topics | Class Hierarchy | nvLimitedBallJoint Methods | nvLimitedBallJoint Members | nvLimitedBallJoint Methods
nV Physics SDK
nvLimitedBallJoint Class
nvJoint
    nvLimitedBallJoint
C++
public: class nvLimitedBallJoint : public nvJoint;
File

Joint.h

Remarks

Ball joint with limits and motors on all axis.

Topics
nvLimitedBallJoint Class
nvLimitedBallJoint Members | The following tables list the members exposed by nvLimitedBallJoint.
nvLimitedBallJoint Methods | The methods of the nvLimitedBallJoint class are listed here.
nvLimitedBallJoint Methods
nvLimitedBallJoint Class
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.
See Also
Classes | Members | Topics | Class Hierarchy | nvLimitedBallJoint Methods | nvLimitedBallJoint Members | nvLimitedBallJoint Methods


nvLimitedBallJoint Members

nvLimitedBallJoint Class | Public Methods
nvLimitedBallJoint Members

The following tables list the members exposed by nvLimitedBallJoint.

Public Methods
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.
See Also
nvLimitedBallJoint Class | Public Methods


nvLimitedBallJoint Methods

nvLimitedBallJoint Class | Public Methods
nvLimitedBallJoint Methods

The methods of the nvLimitedBallJoint class are listed here.

Public Methods
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.
See Also
nvLimitedBallJoint Class | Public Methods


nvLimitedBallJoint::GetAnchor Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::GetAnchor Method
C++
public: void GetAnchor(
    nvReal& anchorX,
    nvReal& anchorY,
    nvReal& anchorZ
);
Remarks

Returns the world coordinates of the joint's anchor.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvLimitedBallJoint::GetAngle Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::GetAngle Method
C++
public: float GetAngle(
    int axis
);
Remarks

Returns the angle (euler angles) between the two bodies along the specified axis.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvLimitedBallJoint::SetMaxLimit Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::SetMaxLimit Method
C++
public: void SetMaxLimit(
    int axis,
    float minAngle
);
Remarks

Sets maximum angle for the specified axis in radians.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvLimitedBallJoint::SetMaxTorque Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::SetMaxTorque Method
C++
public: void SetMaxTorque(
    int axis,
    float MaxTorque
);
Remarks

Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvLimitedBallJoint::SetMinLimit Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::SetMinLimit Method
C++
public: void SetMinLimit(
    int axis,
    float minAngle
);
Remarks

Sets minimum angle for the specified axis in radians.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvLimitedBallJoint::SetRequiredVelocity Method

nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members
nV Physics SDK
nvLimitedBallJoint::SetRequiredVelocity Method
C++
public: void SetRequiredVelocity(
    int axis,
    float vel
);
Remarks

Sets the required angular velocity for the joint about the specified axis in radians per second.

See Also
nvLimitedBallJoint Methods | nvLimitedBallJoint Class | nvLimitedBallJoint Members


nvPhysicsWorld Class

Classes | Members | Topics | Class Hierarchy | nvPhysicsWorld Data Members | nvPhysicsWorld Methods | nvPhysicsWorld Members | nvPhysicsWorld Data Members | nvPhysicsWorld Methods
nV Physics SDK
nvPhysicsWorld Class
nvPhysicsWorld
C++
public: class nvPhysicsWorld;
File

PhysicsWorld.h

Remarks

The physics world. The only object the user should instantiate manually. The root of the physics system.

Topics
nvPhysicsWorld Members | The following tables list the members exposed by nvPhysicsWorld.
nvPhysicsWorld Data Members | The data members of the nvPhysicsWorld class are listed here.
nvPhysicsWorld Methods | The methods of the nvPhysicsWorld class are listed here.
nvPhysicsWorld Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).
nvPhysicsWorld Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.
See Also
Classes | Members | Topics | Class Hierarchy | nvPhysicsWorld Data Members | nvPhysicsWorld Methods | nvPhysicsWorld Members | nvPhysicsWorld Data Members | nvPhysicsWorld Methods


nvPhysicsWorld Members

nvPhysicsWorld Class | Public Data Members | Public Methods
nvPhysicsWorld Members

The following tables list the members exposed by nvPhysicsWorld.

Public Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).
Public Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.
See Also
nvPhysicsWorld Class | Public Data Members | Public Methods


nvPhysicsWorld Data Members

nvPhysicsWorld Class | Public Data Members
nvPhysicsWorld Data Members

The data members of the nvPhysicsWorld class are listed here.

Public Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).
See Also
nvPhysicsWorld Class | Public Data Members


nvPhysicsWorld::BodyMngr Data Member

nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::BodyMngr Data Member
C++
public: nvBodyMngr BodyMngr;
Remarks

The body manager, responsible for creation and destruction of physics bodies.

See Also
nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::JointMngr Data Member

nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::JointMngr Data Member
C++
public: nvJointMngr JointMngr;
Remarks

The joint manager, responsible for creation and destruction of joints (constraints).

See Also
nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::ShapeMngr Data Member

nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::ShapeMngr Data Member
C++
public: nvShapeMngr ShapeMngr;
Remarks

The shape manager, responsible for defining and managing shapes (geometrical setup).

See Also
nvPhysicsWorld Data Members | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld Methods

nvPhysicsWorld Class | Public Methods
nvPhysicsWorld Methods

The methods of the nvPhysicsWorld class are listed here.

Public Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.
See Also
nvPhysicsWorld Class | Public Methods


nvPhysicsWorld::GetNoOfSolvingIterations Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::GetNoOfSolvingIterations Method
C++
public: int GetNoOfSolvingIterations();
Remarks

Returns number of solving iterations, useful for mulithreading.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::GetTimeStep Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::GetTimeStep Method
C++
public: nvReal GetTimeStep();
Remarks

Returns current timestep, useful for multi-threading.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::Reset Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::Reset Method
C++
public: void Reset();
Remarks

Resets the physics world (currently buggy, so better destoy the object instead).

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


RunStep Method

nvPhysicsWorld Methods
RunStep Method
Overload List
nvPhysicsWorld::RunStep (nvReal) | Proceeds the simulation with a given timestep. It is recommended that the timesteps do not greatly vary in length for a good simulation. Too long steps might produce bad side effects too.
nvPhysicsWorld::RunStep (nvReal, nvReal, int) | Proceeds the simulation with a given timestep, with substepping to enhance simulation. Better used when the basic timestep is too long.
See Also
nvPhysicsWorld Methods


nvPhysicsWorld::RunStep Method (nvReal)

RunStep Method | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::RunStep Method (nvReal)
C++
public: void RunStep(
    nvReal dtInSeconds
);
Remarks

Proceeds the simulation with a given timestep. It is recommended that the timesteps do not greatly vary in length for a good simulation. Too long steps might produce bad side effects too.

See Also
RunStep Method | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::RunStep Method (nvReal, nvReal, int)

RunStep Method | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::RunStep Method (nvReal, nvReal, int)
C++
public: void RunStep(
    nvReal dtInSeconds,
    nvReal MaxDtInSeconds,
    int MaxNoOfTimeSegments
);
Remarks

Proceeds the simulation with a given timestep, with substepping to enhance simulation. Better used when the basic timestep is too long.

See Also
RunStep Method | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetBroadPhase Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetBroadPhase Method
C++
public: void SetBroadPhase(
    eBroadPhaseModes mode
);
Remarks

Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)
See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetCFM Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetCFM Method
C++
public: void SetCFM(
    nvReal CFM
);
Parameters
Parameters | Description
CFM | Positive small real number. (0.001 might be a good candidate)
Remarks

Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetCollisionNotify Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetCollisionNotify Method
C++
public: void SetCollisionNotify(
    CollisionNotifyBackFnc FnAddr
);
Remarks

Sets the collision call-back function to a user supplied function.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetGravity Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetGravity Method
C++
public: void SetGravity(
    nvReal xAcceleration,
    nvReal yAcceleration,
    nvReal zAcceleration
);
Remarks

Sets gravity vector. uint: m/s*s

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetNoOfSolvingIterations Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetNoOfSolvingIterations Method
C++
public: void SetNoOfSolvingIterations(
    int NoOfIterations
);
Parameters
Parameters | Description
NoOfIterations | > 0
Remarks

Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPhysicsWorld::SetObjectsAutoDeactivation Method

nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members
nV Physics SDK
nvPhysicsWorld::SetObjectsAutoDeactivation Method
C++
public: void SetObjectsAutoDeactivation(
    bool AutoDeactivateObjects
);
Remarks

Allows still objects to be deactivated untill an external actor affects it.

See Also
nvPhysicsWorld Methods | nvPhysicsWorld Class | nvPhysicsWorld Members


nvPlaneShape Class

Classes | Members | Topics | Class Hierarchy | nvPlaneShape Methods | nvPlaneShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvPlaneShape Class
nvShape
    nvPlaneShape
C++
public: class nvPlaneShape : public nvShape;
File

PlaneShape.h

Remarks

Class used to hold plane shape data

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvPlaneShape Class
nvPlaneShape Members | The following tables list the members exposed by nvPlaneShape.
nvPlaneShape Methods | The methods of the nvPlaneShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvPlaneShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvPlaneShape Methods | nvPlaneShape Members | nvShape Enumerations | nvShape Methods


nvPlaneShape Members

Enumerations | nvPlaneShape Class | Public Methods
nvPlaneShape Members

The following tables list the members exposed by nvPlaneShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvPlaneShape Class | Public Methods


nvPlaneShape Methods

nvPlaneShape Class | Public Methods
nvPlaneShape Methods

The methods of the nvPlaneShape class are listed here.

Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvPlaneShape Class | Public Methods


nvPlaneShape::GetBoundingRadius Method

nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members
nV Physics SDK
nvPlaneShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members


nvPlaneShape::GetBoundingRadiusSqr Method

nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members
nV Physics SDK
nvPlaneShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere. :) What the heck?!

See Also
nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members


nvPlaneShape::GetType Method

nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members
nV Physics SDK
nvPlaneShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvPlaneShape Methods | nvPlaneShape Class | nvPlaneShape Members


nvPrimitive Class

Classes | Members | Topics | Class Hierarchy | nvPrimitive Methods | nvPrimitive Members | nvPrimitive Methods
nV Physics SDK
nvPrimitive Class
nvPrimitive
C++
public: class nvPrimitive;
File

Primitive.h

Remarks

Class used to represent primitives. Each primitve has a shape, and is a part of one body.

Topics
nvPrimitive Members | The following tables list the members exposed by nvPrimitive.
nvPrimitive Methods | The methods of the nvPrimitive class are listed here.
nvPrimitive Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.
See Also
Classes | Members | Topics | Class Hierarchy | nvPrimitive Methods | nvPrimitive Members | nvPrimitive Methods


nvPrimitive Members

nvPrimitive Class | Public Methods
nvPrimitive Members

The following tables list the members exposed by nvPrimitive.

Public Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.
See Also
nvPrimitive Class | Public Methods


nvPrimitive Methods

nvPrimitive Class | Public Methods
nvPrimitive Methods

The methods of the nvPrimitive class are listed here.

Public Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.
See Also
nvPrimitive Class | Public Methods


nvPrimitive::GetBody Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetBody Method
C++
public: nvBody* GetBody();
Remarks

Returns associated shape.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetData Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetData Method
C++
public: void* GetData();
Remarks

Returns a pointer to the associated user defined data.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetElasticity Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetElasticity Method
C++
public: nvReal GetElasticity();
Remarks

Returns the elasticity coefficient of the primitive.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetFriction Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetFriction Method
C++
public: nvReal GetFriction();
Remarks

Returns the friction coefficient of the primitive.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetLocalPosition Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetLocalPosition Method
C++
public: void GetLocalPosition(
    nvReal & x,
    nvReal & y,
    nvReal & z
);
Remarks

Returns the position of the primitive relatively to the body's coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetLocalRotationMatrix Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetLocalRotationMatrix Method
C++
public: nvReal* GetLocalRotationMatrix();
Remarks

Returns a 3x3 rotation matrix relative to the body's coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetShape Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetShape Method
C++
public: nvShape* GetShape();
Remarks

Returns containing body.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetWorldPosition Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetWorldPosition Method
C++
public: void GetWorldPosition(
    nvReal & x,
    nvReal & y,
    nvReal & z
);
Remarks

Sets the position of the primitive relatively to the worlds coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::GetWorldRotationMatrix Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::GetWorldRotationMatrix Method
C++
public: nvReal* GetWorldRotationMatrix();
Remarks

Returns a 3x3 rotation matrix relative to the world coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::RotateAxisAngle Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::RotateAxisAngle Method
C++
public: void RotateAxisAngle(
    nvReal xAxis,
    nvReal yAxis,
    nvReal zAxis,
    nvReal angle
);
Remarks

Used to set the rotation of the primitive relatively to the body's space.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::SetData Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::SetData Method
C++
public: void SetData(
    void * pData
);
Remarks

As with bodies, each primitive can be associated with any user defined data pointer.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::SetElasticity Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::SetElasticity Method
C++
public: void SetElasticity(
    nvReal elasticity
);
Remarks

Sets elasticity coefficient.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::SetFriction Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::SetFriction Method
C++
public: void SetFriction(
    nvReal friction
);
Remarks

Sets friction coefficient.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::SetLocalPosition Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::SetLocalPosition Method
C++
public: void SetLocalPosition(
    nvReal x,
    nvReal y,
    nvReal z
);
Remarks

Sets the position of the primitive relatively to the body's coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvPrimitive::SetLocalRotation Method

nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members
nV Physics SDK
nvPrimitive::SetLocalRotation Method
C++
public: void SetLocalRotation(
    nvReal* p3x3
);
Remarks

Sets the rotation matrix of the primitive relatively to the body's coordinates.

See Also
nvPrimitive Methods | nvPrimitive Class | nvPrimitive Members


nvShape Class

Classes | Members | Topics | Class Hierarchy | nvShape Enumerations | nvShape Methods | nvShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvShape Class
nvShape
    nvBoxShape
    nvConvexShape
    nvCylinderShape
    nvPlaneShape
    nvSphereShape
    nvTriMeshShape
C++
public: class nvShape;
File

Shape.h

Remarks

Base class for shape representation classes.

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvShape Enumerations | nvShape Methods | nvShape Members | nvShape Enumerations | nvShape Methods


nvShape Members

Enumerations | nvShape Class | Public Methods
nvShape Members

The following tables list the members exposed by nvShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvShape Class | Public Methods


nvShape Enumerations

Enumerations | nvShape Class
nvShape Enumerations

The enumerations of the nvShape class are listed here.

Enumerations
eShapeType
Enum specifying the shape class
See Also
Enumerations | nvShape Class


nvShape::eShapeType Enumeration

nvShape Enumerations
nvShape::eShapeType Enumeration
C++
public: enum eShapeType {
};
File

Shape.h

Remarks

Enum specifying the shape class

See Also
nvShape Enumerations


nvShape Methods

nvShape Class | Public Methods
nvShape Methods

The methods of the nvShape class are listed here.

Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvShape Class | Public Methods


nvShape::GetBoundingRadius Method

nvShape Methods | nvShape Class | nvShape Members
nvShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvShape Methods | nvShape Class | nvShape Members


nvShape::GetBoundingRadiusSqr Method

nvShape Methods | nvShape Class | nvShape Members
nvShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere. :) What the heck?!

See Also
nvShape Methods | nvShape Class | nvShape Members


nvShape::GetType Method

nvShape Methods | nvShape Class | nvShape Members
nvShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvShape Methods | nvShape Class | nvShape Members


nvShapeMngr Class

Classes | Members | Topics | Class Hierarchy | nvShapeMngr Methods | nvShapeMngr Members | nvShapeMngr Methods
nV Physics SDK
nvShapeMngr Class
nvShapeMngr
C++
public: class nvShapeMngr;
File

ShapeMngr.h

Remarks

The class responsible for creating and managing shapes (geometrical setups).

Topics
nvShapeMngr Members | The following tables list the members exposed by nvShapeMngr.
nvShapeMngr Methods | The methods of the nvShapeMngr class are listed here.
nvShapeMngr Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.
See Also
Classes | Members | Topics | Class Hierarchy | nvShapeMngr Methods | nvShapeMngr Members | nvShapeMngr Methods


nvShapeMngr Members

nvShapeMngr Class | Public Methods
nvShapeMngr Members

The following tables list the members exposed by nvShapeMngr.

Public Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.
See Also
nvShapeMngr Class | Public Methods


nvShapeMngr Methods

nvShapeMngr Class | Public Methods
nvShapeMngr Methods

The methods of the nvShapeMngr class are listed here.

Public Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.
See Also
nvShapeMngr Class | Public Methods


nvShapeMngr::CreateBox Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::CreateBox Method
C++
public: nvBoxShape* CreateBox(
    nvReal xLength,
    nvReal yLength,
    nvReal zLength
);
Remarks

Create a box shape, given its dimentions.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::CreateConvex Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::CreateConvex Method
C++
public: nvConvexShape* CreateConvex();
Remarks

Create an empty convex shape.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::CreateCylinder Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::CreateCylinder Method
C++
public: nvCylinderShape* CreateCylinder(
    nvReal radius,
    nvReal height
);
Remarks

Create a cylinder shape, given its radius and height.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


CreatePlane Method

nvShapeMngr Methods
CreatePlane Method
Overload List
nvShapeMngr::CreatePlane (nvReal, nvReal, nvReal, nvReal) | Create a plane shape, given a normal and a coefficient.
nvShapeMngr::CreatePlane (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal) | Create a plane shape, given a normal and a point.
See Also
nvShapeMngr Methods


nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal)

CreatePlane Method | nvShapeMngr Class | nvShapeMngr Members
nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal)
C++
public: nvPlaneShape* CreatePlane(
    nvReal nx,
    nvReal ny,
    nvReal nz,
    nvReal d
);
Remarks

Create a plane shape, given a normal and a coefficient.

See Also
CreatePlane Method | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)

CreatePlane Method | nvShapeMngr Class | nvShapeMngr Members
nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
C++
public: nvPlaneShape* CreatePlane(
    nvReal xPointOnPlane,
    nvReal yPointOnPlane,
    nvReal zPointOnPlane,
    nvReal xNormalOnPlane,
    nvReal yNormalOnPlane,
    nvReal zNormalOnPlane
);
Remarks

Create a plane shape, given a normal and a point.

See Also
CreatePlane Method | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::CreateSphere Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::CreateSphere Method
C++
public: nvSphereShape* CreateSphere(
    nvReal radius
);
Remarks

Create a sphere shape, given its radius.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::CreateTriMesh Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::CreateTriMesh Method
C++
public: nvTriMeshShape* CreateTriMesh();
Remarks

Create an empty triangle mesh shape.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


nvShapeMngr::DestroyShape Method

nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members
nV Physics SDK
nvShapeMngr::DestroyShape Method
C++
public: void DestroyShape(
    nvShape* pShape
);
Remarks

Destroys a shape, rarely used.

See Also
nvShapeMngr Methods | nvShapeMngr Class | nvShapeMngr Members


nvSphereShape Class

Classes | Members | Topics | Class Hierarchy | nvSphereShape Methods | nvSphereShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvSphereShape Class
nvShape
    nvSphereShape
C++
public: class nvSphereShape : public nvShape;
File

SphereShape.h

Remarks

Class used to hold sphere shape data, needs cleanup?!

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvSphereShape Class
nvSphereShape Members | The following tables list the members exposed by nvSphereShape.
nvSphereShape Methods | The methods of the nvSphereShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvSphereShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvSphereShape Methods | nvSphereShape Members | nvShape Enumerations | nvShape Methods


nvSphereShape Members

Enumerations | nvSphereShape Class | Public Methods
nvSphereShape Members

The following tables list the members exposed by nvSphereShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvSphereShape Class | Public Methods


nvSphereShape Methods

nvSphereShape Class | Public Methods
nvSphereShape Methods

The methods of the nvSphereShape class are listed here.

Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvSphereShape Class | Public Methods


nvSphereShape::GetBoundingRadius Method

nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members
nV Physics SDK
nvSphereShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members


nvSphereShape::GetBoundingRadiusSqr Method

nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members
nV Physics SDK
nvSphereShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere. :) What the heck?!

See Also
nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members


nvSphereShape::GetRadius Method

nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members
nV Physics SDK
nvSphereShape::GetRadius Method
C++
public: nvReal GetRadius();
Remarks

Return the Radius of the sphere shape.

See Also
nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members


nvSphereShape::GetType Method

nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members
nV Physics SDK
nvSphereShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvSphereShape Methods | nvSphereShape Class | nvSphereShape Members


nvTriMeshShape Class

Classes | Members | Topics | Class Hierarchy | nvTriMeshShape Methods | nvTriMeshShape Members | nvShape Enumerations | nvShape Methods
nV Physics SDK
nvTriMeshShape Class
nvShape
    nvTriMeshShape
C++
public: class nvTriMeshShape : public nvShape;
File

TriMeshShape.h

Remarks

The shape class representing a STATIC triangle mesh.

Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvTriMeshShape Class
nvTriMeshShape Members | The following tables list the members exposed by nvTriMeshShape.
nvTriMeshShape Methods | The methods of the nvTriMeshShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvTriMeshShape Class
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Classes | Members | Topics | Class Hierarchy | nvTriMeshShape Methods | nvTriMeshShape Members | nvShape Enumerations | nvShape Methods


nvTriMeshShape Members

Enumerations | nvTriMeshShape Class | Public Methods
nvTriMeshShape Members

The following tables list the members exposed by nvTriMeshShape.

Enumerations
eShapeType
Enum specifying the shape class
Public Methods
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
Enumerations | nvTriMeshShape Class | Public Methods


nvTriMeshShape Methods

nvTriMeshShape Class | Public Methods
nvTriMeshShape Methods

The methods of the nvTriMeshShape class are listed here.

Public Methods
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
See Also
nvTriMeshShape Class | Public Methods


nvTriMeshShape::AddTriangle Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::AddTriangle Method
C++
public: void AddTriangle(
    nvReal* V1,
    nvReal* V2,
    nvReal* V3
);
Parameters
Parameters | Description
V1 | A vector representing the first point (3 consecutive real numbers).
V2 | A vector representing the second point (3 consecutive real numbers).
V3 | A vector representing the third point (3 consecutive real numbers).
Remarks

Adds a triangle to the triangle mesh.

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


nvTriMeshShape::Begin Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::Begin Method
C++
public: void Begin();
Remarks

Called before adding triangles.

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


nvTriMeshShape::End Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::End Method
C++
public: void End();
Remarks

Called after finishing adding triangles.

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


nvTriMeshShape::GetBoundingRadius Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::GetBoundingRadius Method
C++
public: virtual nvReal GetBoundingRadius();
Remarks

Return the radius of the shape's bounding sphere.

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


nvTriMeshShape::GetBoundingRadiusSqr Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::GetBoundingRadiusSqr Method
C++
public: virtual nvReal GetBoundingRadiusSqr();
Remarks

Return the square root of the radius of the shape's bounding sphere. :) What the heck?!

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


nvTriMeshShape::GetType Method

nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members
nV Physics SDK
nvTriMeshShape::GetType Method
C++
public: virtual nvShape::eShapeType GetType();
Remarks

get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.

See Also
nvTriMeshShape Methods | nvTriMeshShape Class | nvTriMeshShape Members


Structs, Records, Enums

Enumerations
Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
eBroadPhaseModes
Enumeration used to specify the broad-phase collision detection algorithm.

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

See Also
Enumerations


eBroadPhaseModes Enumeration

Structs, Records, Enums
eBroadPhaseModes Enumeration
C++
public: enum eBroadPhaseModes {
};
File

PhysicsWorld.h

Remarks

Enumeration used to specify the broad-phase collision detection algorithm.

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)
See Also
Structs, Records, Enums


Types

Types
Types

The following table lists types in this documentation.

Types
CollisionNotifyBackFnc | Collision call-back function.
nvReal | should be defined double when using the double precision version of the library.
See Also
Types


CollisionNotifyBackFnc Type

Types
CollisionNotifyBackFnc Type
C++
typedef bool (__cdecl * CollisionNotifyBackFnc)(void * pPrim1 ,void* pPrim2 ,nvReal *ContactPoints,int NoOfContactPoints);
File

PhysicsWorld.h

Remarks

Collision call-back function.

See Also
Types


nvReal Type

Types
nvReal Type
C++
typedef float nvReal;
File

types.h

Remarks

should be defined double when using the double precision version of the library.

See Also
Types


Classes

Classes
Classes
Classes
nvBody | The class representing a physical body, each nvBody is composed of one or more nvPrimitive (s)
nvBodyMngr | nvBodyMngr is the class responsible create and destroy physics bodies (nvBody). Each nvPhysicsWorld has an instance of nvBodyMngr.
nvBoxShape | Class used to hold box shape data.
nvCarWheelJoint | Car wheel joint with steering angle and suspension.
nvConvexShape | Class used to hold convex shape data.
nvCylinderShape | Class used to hold cylinder shape data.
nvDoubleHingeJoint | Double-hinge joint (hinge2)
nvHingeJoint | Hinge Joint
nvJoint | Base class for joints (constraints).
nvJointMngr | nvJointMngr is the class responsible create and destroy nvJoints (constraints). Each nvPhysicsWorld has an instance of nvJointMngr.
nvLimitedBallJoint | Ball joint with limits and motors on all axis.
nvPhysicsWorld | The physics world. The only object the user should instantiate manually. The root of the physics system.
nvPlaneShape | Class used to hold plane shape data
nvPrimitive | Class used to represent primitives. Each primitve has a shape, and is a part of one body.
nvShape | Base class for shape representation classes.
nvShapeMngr | The class responsible for creating and managing shapes (geometrical setups).
nvSphereShape | Class used to hold sphere shape data, needs cleanup?!
nvTriMeshShape | The shape class representing a STATIC triangle mesh.


nvBody Members Public Data Members

nvBody Members Public Data Members
nvBody Members
Public Data Members
Primitives
List of primitives contained in the body.


Public Data Members

Legend
Legend
Data Member


nvBody Members Public Methods

nvBody Members Public Methods
nvBody Members
Public Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.


Public Methods

Legend
Legend
Method


nvBodyMngr Members Public Methods

nvBodyMngr Members Public Methods
nvBodyMngr Members
Public Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.


nvBoxShape Members Enumerations

nvBoxShape Members Enumerations
nvBoxShape Members
Enumerations
eShapeType
Enum specifying the shape class


Enumerations

Legend
Legend
Enumeration


nvBoxShape Members Public Methods

nvBoxShape Members Public Methods
nvBoxShape Members
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.


Public Methods

Legend
Legend
Method
virtual


nvCarWheelJoint Members Public Methods

nvCarWheelJoint Members Public Methods
nvCarWheelJoint Members
Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.


nvConvexShape Members Enumerations

nvConvexShape Members Enumerations
nvConvexShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvConvexShape Members Public Methods

nvConvexShape Members Public Methods
nvConvexShape Members
Public Methods
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvCylinderShape Members Enumerations

nvCylinderShape Members Enumerations
nvCylinderShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvCylinderShape Members Public Methods

nvCylinderShape Members Public Methods
nvCylinderShape Members
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvDoubleHingeJoint Members Public Methods

nvDoubleHingeJoint Members Public Methods
nvDoubleHingeJoint Members
Public Methods
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.


nvHingeJoint Members Public Methods

nvHingeJoint Members Public Methods
nvHingeJoint Members
Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.


nvJointMngr Members Public Methods

nvJointMngr Members Public Methods
nvJointMngr Members
Public Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.


nvLimitedBallJoint Members Public Methods

nvLimitedBallJoint Members Public Methods
nvLimitedBallJoint Members
Public Methods
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.


nvPhysicsWorld Members Public Data Members

nvPhysicsWorld Members Public Data Members
nvPhysicsWorld Members
Public Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).


nvPhysicsWorld Members Public Methods

nvPhysicsWorld Members Public Methods
nvPhysicsWorld Members
Public Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.


nvPlaneShape Members Enumerations

nvPlaneShape Members Enumerations
nvPlaneShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvPlaneShape Members Public Methods

nvPlaneShape Members Public Methods
nvPlaneShape Members
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvPrimitive Members Public Methods

nvPrimitive Members Public Methods
nvPrimitive Members
Public Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.


nvShape Members Enumerations

nvShape Members Enumerations
nvShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvShape Members Public Methods

nvShape Members Public Methods
nvShape Members
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShapeMngr Members Public Methods

nvShapeMngr Members Public Methods
nvShapeMngr Members
Public Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.


nvSphereShape Members Enumerations

nvSphereShape Members Enumerations
nvSphereShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvSphereShape Members Public Methods

nvSphereShape Members Public Methods
nvSphereShape Members
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvTriMeshShape Members Enumerations

nvTriMeshShape Members Enumerations
nvTriMeshShape Members
Enumerations
eShapeType
Enum specifying the shape class


nvTriMeshShape Members Public Methods

nvTriMeshShape Members Public Methods
nvTriMeshShape Members
Public Methods
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvBody Data Members Public Data Members

nvBody Data Members Public Data Members
nvBody Data Members
Public Data Members
Primitives
List of primitives contained in the body.


nvPhysicsWorld Data Members Public Data Members

nvPhysicsWorld Data Members Public Data Members
nvPhysicsWorld Data Members
Public Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).


nvShape Enumerations Enumerations

nvShape Enumerations Enumerations
nvShape Enumerations
Enumerations
eShapeType
Enum specifying the shape class


nvBody Methods Public Methods

nvBody Methods Public Methods
nvBody Methods
Public Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.


nvBodyMngr Methods Public Methods

nvBodyMngr Methods Public Methods
nvBodyMngr Methods
Public Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.


nvBoxShape Methods Public Methods

nvBoxShape Methods Public Methods
nvBoxShape Methods
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvCarWheelJoint Methods Public Methods

nvCarWheelJoint Methods Public Methods
nvCarWheelJoint Methods
Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.


nvConvexShape Methods Public Methods

nvConvexShape Methods Public Methods
nvConvexShape Methods
Public Methods
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvCylinderShape Methods Public Methods

nvCylinderShape Methods Public Methods
nvCylinderShape Methods
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvDoubleHingeJoint Methods Public Methods

nvDoubleHingeJoint Methods Public Methods
nvDoubleHingeJoint Methods
Public Methods
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.


nvHingeJoint Methods Public Methods

nvHingeJoint Methods Public Methods
nvHingeJoint Methods
Public Methods
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.


nvJointMngr Methods Public Methods

nvJointMngr Methods Public Methods
nvJointMngr Methods
Public Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.


nvLimitedBallJoint Methods Public Methods

nvLimitedBallJoint Methods Public Methods
nvLimitedBallJoint Methods
Public Methods
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.


nvPhysicsWorld Methods Public Methods

nvPhysicsWorld Methods Public Methods
nvPhysicsWorld Methods
Public Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.


nvPlaneShape Methods Public Methods

nvPlaneShape Methods Public Methods
nvPlaneShape Methods
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvPrimitive Methods Public Methods

nvPrimitive Methods Public Methods
nvPrimitive Methods
Public Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.


nvShape Methods Public Methods

nvShape Methods Public Methods
nvShape Methods
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShapeMngr Methods Public Methods

nvShapeMngr Methods Public Methods
nvShapeMngr Methods
Public Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.


nvSphereShape Methods Public Methods

nvSphereShape Methods Public Methods
nvSphereShape Methods
Public Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvTriMeshShape Methods Public Methods

nvTriMeshShape Methods Public Methods
nvTriMeshShape Methods
Public Methods
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Structs, Records, Enums Enumerations

Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
eBroadPhaseModes
Enumeration used to specify the broad-phase collision detection algorithm.

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)


Types

Types
Types
Types
CollisionNotifyBackFnc | Collision call-back function.
nvReal | should be defined double when using the double precision version of the library.


nvBody Data Members

nvBody Data Members
nvBody Class
nvBody Data Members
Primitives
List of primitives contained in the body.


Data Members (AutoDoc Folder)

Legend
Legend
Data Member


nvBody Class Members

nvBody Class Members
nvBody Class
Members
Topics
nvBody Members | The following tables list the members exposed by nvBody.
nvBody Data Members | The data members of the nvBody class are listed here.
nvBody Methods | The methods of the nvBody class are listed here.
nvBody Data Members
Primitives
List of primitives contained in the body.
nvBody Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.


Members

Legend
Legend
Data Member
Method


nvBody Methods

nvBody Methods
nvBody Class
nvBody Methods
AddBox | Adds a box primitive to the body.
AddConvex | Adds a convex primitive to the body.
AddCylinder | Adds a cylinder primitive to the body.
AddNewPrimitive | Adds a primitive to the body.
AddOneFrameForce |
AddOneFrameTorque | Affects the body with the specified torque for the time of the next physics step. Specified as a vector in newton-metres.
AddPermanentForce |
AddPermanentTorque | Affects the body with the specified torque that continues forever. Specified as a vector in newton-metres.
AddPlane |
AddSphere | Adds a sphere primitive to the body.
AddTriMesh | Adds a triangle mesh primitive to the body.
GetAngularVelocity | Returns angular velocity of the body. (expressed as a vector in radians per second)
GetCenterOfMass | Returns the center of mass for the body at hand.
GetData | Gets the user defined data associated with the body if any.
GetLinearVelocity | Returns linear velocity of the body. (expressed as a vector in meters per second)
GetMass | Returns the body's mass in kilograms.
GetPositon | Returns the body's world coordinates.
GetRotationMatrix | Returns a 3x3 rotation matrix.
IsSleeping | Indicates whether the body is deactivated.
IsStatic | Indicates whether the body is static (not controlled by physics).
Move | Instantaniously moves the body to the specified world coordinates.
RotateAxisAngle | Rotates a body about a specified axis with a specified angle.
SetAngularVelocity | Sets the angular velocity for the body. (expressed as a vector in radians per second)
SetData | Associates the body data structure with any user defined data.
SetLinearVelocity | Sets the linear velocity for the body. (expressed as a vector in meters per second)
SetPosition | Sets the body's world coordinates.


Methods (AutoDoc Folder)

Legend
Legend
Method


Topics

Topics
nvBody Class
Topics
nvBody Members | The following tables list the members exposed by nvBody.
nvBody Data Members | The data members of the nvBody class are listed here.
nvBody Methods | The methods of the nvBody class are listed here.


Class Hierarchy

Class Hierarchy
nvBody Class
Class Hierarchy
nvBody


nvBodyMngr Class Members

nvBodyMngr Class Members
nvBodyMngr Class
Members
Topics
nvBodyMngr Members | The following tables list the members exposed by nvBodyMngr.
nvBodyMngr Methods | The methods of the nvBodyMngr class are listed here.
nvBodyMngr Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.


Members

Legend
Legend
Method


nvBodyMngr Methods

nvBodyMngr Methods
nvBodyMngr Class
nvBodyMngr Methods
Create | Simply creates a new physics body.
Destroy | Similarly destroys the body.


Topics

Topics
nvBodyMngr Class
Topics
nvBodyMngr Members | The following tables list the members exposed by nvBodyMngr.
nvBodyMngr Methods | The methods of the nvBodyMngr class are listed here.


Class Hierarchy

Class Hierarchy
nvBodyMngr Class
Class Hierarchy
nvBodyMngr


nvShape Enumerations

nvShape Enumerations
nvBoxShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


Enumerations (AutoDoc Folder)

Legend
Legend
Enumeration


nvBoxShape Class Members

nvBoxShape Class Members
nvBoxShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvBoxShape Class
nvBoxShape Members | The following tables list the members exposed by nvBoxShape.
nvBoxShape Methods | The methods of the nvBoxShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvBoxShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.


Members

Legend
Legend
Enumeration
Method
virtual


nvShape Methods

nvShape Methods
nvBoxShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvBoxShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetDimensions | Returns the three dimentions of the box shape.
GetType | get the type before u cast! Is this used at all?! Return an enumeration indicating the specific class of the shape.


Methods (AutoDoc Folder)

Legend
Legend
Method
virtual


Topics

Topics
nvBoxShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvBoxShape Class
nvBoxShape Members | The following tables list the members exposed by nvBoxShape.
nvBoxShape Methods | The methods of the nvBoxShape class are listed here.


Class Hierarchy

Class Hierarchy
nvBoxShape Class
Class Hierarchy
nvShape
    nvBoxShape


nvCarWheelJoint Class Members

nvCarWheelJoint Class Members
nvCarWheelJoint Class
Members
Topics
nvCarWheelJoint Class
nvCarWheelJoint Members | The following tables list the members exposed by nvCarWheelJoint.
nvCarWheelJoint Methods | The methods of the nvCarWheelJoint class are listed here.
nvCarWheelJoint Methods
nvCarWheelJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.


nvCarWheelJoint Methods

nvCarWheelJoint Methods
nvCarWheelJoint Class
nvCarWheelJoint Methods
nvCarWheelJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.
SetSteeringAngle | Sets the steering angle of the wheel.


Topics

Topics
nvCarWheelJoint Class
Topics
nvCarWheelJoint Class
nvCarWheelJoint Members | The following tables list the members exposed by nvCarWheelJoint.
nvCarWheelJoint Methods | The methods of the nvCarWheelJoint class are listed here.


Class Hierarchy

Class Hierarchy
nvCarWheelJoint Class
Class Hierarchy
nvJoint
    nvCarWheelJoint


nvShape Enumerations

nvShape Enumerations
nvConvexShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvConvexShape Class Members

nvConvexShape Class Members
nvConvexShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvConvexShape Class
nvConvexShape Members | The following tables list the members exposed by nvConvexShape.
nvConvexShape Methods | The methods of the nvConvexShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvConvexShape Class
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvConvexShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvConvexShape Class
AddEdge | Adds a new edge, by putting 2 vertices, and one edge.
AddIndexedTriangleFan | adds an indexed triangle fan.
AddIndexedTriangles | Adds a list of indexed triangles using just 1 pointer to the vertices and a pointer to the indices we take 3 x,y,z values by jumping by the stride values each 3 vertices creates a new face.
AddIndexedTriangleStrip | Adds an indexed triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddTriangle | Adds a new face.. should create one face, and a number of edges= number of vertices, and add the vertices we start with a triangle the 3 vertices are in CCW order.
AddTriangleFan | Adds a triangle fan.
AddTriangles | Adds a list of triangles using just 1 pointer we take 3 x,y,z values by jumping by the stride vlues each 3 vertices creates a new face.
AddTriangleStrip | Adds a triangles strip same as the previous, but the vertices are added in a different way each vertex takes the 2 previous ones, and inverts the order of them.
AddVertices | A faster way to add vertices should be in this form send a pointer to the first vertex and the stride (in bytes) from one vertex to the next data will be copied locally
Begin | these 2 function calls are essential vertices should only be added between a begin and an end
End | call this when done with adding vertices
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvConvexShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvConvexShape Class
nvConvexShape Members | The following tables list the members exposed by nvConvexShape.
nvConvexShape Methods | The methods of the nvConvexShape class are listed here.


Class Hierarchy

Class Hierarchy
nvConvexShape Class
Class Hierarchy
nvShape
    nvConvexShape


nvShape Enumerations

nvShape Enumerations
nvCylinderShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvCylinderShape Class Members

nvCylinderShape Class Members
nvCylinderShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvCylinderShape Class
nvCylinderShape Members | The following tables list the members exposed by nvCylinderShape.
nvCylinderShape Methods | The methods of the nvCylinderShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvCylinderShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvCylinderShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvCylinderShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere.
GetHeight | Returns the height of the cylinder.
GetRadius | Returns radius of the cylinder.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvCylinderShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvCylinderShape Class
nvCylinderShape Members | The following tables list the members exposed by nvCylinderShape.
nvCylinderShape Methods | The methods of the nvCylinderShape class are listed here.


Class Hierarchy

Class Hierarchy
nvCylinderShape Class
Class Hierarchy
nvShape
    nvCylinderShape


nvDoubleHingeJoint Class Members

nvDoubleHingeJoint Class Members
nvDoubleHingeJoint Class
Members
Topics
nvDoubleHingeJoint Class
nvDoubleHingeJoint Members | The following tables list the members exposed by nvDoubleHingeJoint.
nvDoubleHingeJoint Methods | The methods of the nvDoubleHingeJoint class are listed here.
nvDoubleHingeJoint Methods
nvDoubleHingeJoint Class
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.


nvDoubleHingeJoint Methods

nvDoubleHingeJoint Methods
nvDoubleHingeJoint Class
nvDoubleHingeJoint Methods
nvDoubleHingeJoint Class
AddOneFrameTorque1 | Adds a torque about axis-1 to the joint that affects the bodies connected for the next time step. (obsolete)
AddOneFrameTorque2 | Adds a torque about axis-2 to the joint that affects the bodies connected for the next time step. (obsolete)
SetMaxTorque1 | Sets the maximum torque about axis-1 with which the joint can affect the bodies concerned.
SetMaxTorque2 | Sets the maximum torque about axis-2 with which the joint can affect the bodies concerned.
SetRequiredVelocity1 | Sets the required angular velocity about axis-1 for the joint in radians per second.
SetRequiredVelocity2 | Sets the required angular velocity about axis-2 for the joint in radians per second.


Topics

Topics
nvDoubleHingeJoint Class
Topics
nvDoubleHingeJoint Class
nvDoubleHingeJoint Members | The following tables list the members exposed by nvDoubleHingeJoint.
nvDoubleHingeJoint Methods | The methods of the nvDoubleHingeJoint class are listed here.


Class Hierarchy

Class Hierarchy
nvDoubleHingeJoint Class
Class Hierarchy
nvJoint
    nvDoubleHingeJoint


nvHingeJoint Class Members

nvHingeJoint Class Members
nvHingeJoint Class
Members
Topics
nvHingeJoint Class
nvHingeJoint Members | The following tables list the members exposed by nvHingeJoint.
nvHingeJoint Methods | The methods of the nvHingeJoint class are listed here.
nvHingeJoint Methods
nvHingeJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.


nvHingeJoint Methods

nvHingeJoint Methods
nvHingeJoint Class
nvHingeJoint Methods
nvHingeJoint Class
AddOneFrameTorque | Adds a torque to the joint that affects the bodies connected for the next time step.
GetAngle | Returns the current angle of the joint.
GetVelocity | Returns the angular velocity with which the joint moves. (unit: radians per second)
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned.
SetRequiredVelocity | Sets the required angular velocity for the joint in radians per second.


Topics

Topics
nvHingeJoint Class
Topics
nvHingeJoint Class
nvHingeJoint Members | The following tables list the members exposed by nvHingeJoint.
nvHingeJoint Methods | The methods of the nvHingeJoint class are listed here.


Class Hierarchy

Class Hierarchy
nvHingeJoint Class
Class Hierarchy
nvJoint
    nvHingeJoint


Class Hierarchy

Class Hierarchy
nvJoint Class
Class Hierarchy
nvJoint
    nvCarWheelJoint
    nvDoubleHingeJoint
    nvHingeJoint
    nvLimitedBallJoint


nvJointMngr Class Members

nvJointMngr Class Members
nvJointMngr Class
Members
Topics
nvJointMngr Members | The following tables list the members exposed by nvJointMngr.
nvJointMngr Methods | The methods of the nvJointMngr class are listed here.
nvJointMngr Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.


nvJointMngr Methods

nvJointMngr Methods
nvJointMngr Class
nvJointMngr Methods
CreateBallJoint |
CreateCarWheelJoint | Creates a car-wheel joint (ball-socket, point to point) given the two bodies, the anchor, the steering axis and the stiffness of the suspension spring.
CreateDoubleHingeJoint | Creates adouble-hinge joint (hinge2), given two bodies, and anchor and two revolution axis. One axis will be attached to each object respectively.
CreateFixedJoint | Creates a fixed joint between two given bodies.
CreateHingeJoint | Creates a hinge joint between two bodies, given the bodies, the anchor point and the revolution axis.
CreateLimitedBallJoint | Creates a ball joint (ball-socket, point to point) with limits and motors enabled on all three rotation axis.
CreateStiffSpringJoint | Creates a stiff-spring joint (stick) given the two bodies and two points to attach the stick to each body respectively.
CreateUniversalJoint | Creates a universal joint between two bodies, given the bodies, the anchor point and the two revolution axis.
DeleteAllBodyJoints | destroys all joints attached to the specified body. (Useless to expose?)
DestroyJoint | Destroys a given joint.
nvJointMngr::CreatePrismaticJoint | Creates a prismatic joint between two bodies, given the bodies, the anchor point and the transition axis.


Topics

Topics
nvJointMngr Class
Topics
nvJointMngr Members | The following tables list the members exposed by nvJointMngr.
nvJointMngr Methods | The methods of the nvJointMngr class are listed here.


Class Hierarchy

Class Hierarchy
nvJointMngr Class
Class Hierarchy
nvJointMngr


nvLimitedBallJoint Class Members

nvLimitedBallJoint Class Members
nvLimitedBallJoint Class
Members
Topics
nvLimitedBallJoint Class
nvLimitedBallJoint Members | The following tables list the members exposed by nvLimitedBallJoint.
nvLimitedBallJoint Methods | The methods of the nvLimitedBallJoint class are listed here.
nvLimitedBallJoint Methods
nvLimitedBallJoint Class
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.


nvLimitedBallJoint Methods

nvLimitedBallJoint Methods
nvLimitedBallJoint Class
nvLimitedBallJoint Methods
nvLimitedBallJoint Class
GetAnchor | Returns the world coordinates of the joint's anchor.
GetAngle | Returns the angle (euler angles) between the two bodies along the specified axis.
SetMaxLimit | Sets maximum angle for the specified axis in radians.
SetMaxTorque | Sets the maximum torque with which the joint can affect the bodies concerned about the specified axis.
SetMinLimit | Sets minimum angle for the specified axis in radians.
SetRequiredVelocity | Sets the required angular velocity for the joint about the specified axis in radians per second.


Topics

Topics
nvLimitedBallJoint Class
Topics
nvLimitedBallJoint Class
nvLimitedBallJoint Members | The following tables list the members exposed by nvLimitedBallJoint.
nvLimitedBallJoint Methods | The methods of the nvLimitedBallJoint class are listed here.


Class Hierarchy

Class Hierarchy
nvLimitedBallJoint Class
Class Hierarchy
nvJoint
    nvLimitedBallJoint


nvPhysicsWorld Data Members

nvPhysicsWorld Data Members
nvPhysicsWorld Class
nvPhysicsWorld Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).


nvPhysicsWorld Class Members

nvPhysicsWorld Class Members
nvPhysicsWorld Class
Members
Topics
nvPhysicsWorld Members | The following tables list the members exposed by nvPhysicsWorld.
nvPhysicsWorld Data Members | The data members of the nvPhysicsWorld class are listed here.
nvPhysicsWorld Methods | The methods of the nvPhysicsWorld class are listed here.
nvPhysicsWorld Data Members
BodyMngr | The body manager, responsible for creation and destruction of physics bodies.
JointMngr | The joint manager, responsible for creation and destruction of joints (constraints).
ShapeMngr | The shape manager, responsible for defining and managing shapes (geometrical setup).
nvPhysicsWorld Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.


nvPhysicsWorld Methods

nvPhysicsWorld Methods
nvPhysicsWorld Class
nvPhysicsWorld Methods
GetNoOfSolvingIterations
Returns number of solving iterations, useful for mulithreading.
GetTimeStep
Returns current timestep, useful for multi-threading.
Reset
Resets the physics world (currently buggy, so better destoy the object instead).
RunStep
SetBroadPhase
Sets the broad-phase collision detection algorithm. Available algorithms are:

  • NO: No broad phase! (all against all)
  • SIMPLE: Simple broad phase (Slightly better and smarter than the first option, eliminates sleeping bodies).
  • JOINT_GROUP: Joint Groups (based on contact ad joins data, appropriate when the world bodies are divided in multiple distinct groups).
  • SWEEP: Sweep and Prune (performs well for most cases)
  • HGRID: Hierarchical grids (hierarchical space hashing)

SetCFM
Sets CFM (constraint force mixing) coefficient. Helps stabilizing the simulation, on the expense of dampening the contraint system. Each joint can have its CFM value or can inherit this value from the world.
SetCollisionNotify
Sets the collision call-back function to a user supplied function.
SetGravity
Sets gravity vector. uint: m/s*s
SetNoOfSolvingIterations
Specifies the maximum number of solving iterations for the iterative solver. Low numbers guarantee stable frame-rate, high numbers provide more stability.
SetObjectsAutoDeactivation
Allows still objects to be deactivated untill an external actor affects it.


Topics

Topics
nvPhysicsWorld Class
Topics
nvPhysicsWorld Members | The following tables list the members exposed by nvPhysicsWorld.
nvPhysicsWorld Data Members | The data members of the nvPhysicsWorld class are listed here.
nvPhysicsWorld Methods | The methods of the nvPhysicsWorld class are listed here.


Class Hierarchy

Class Hierarchy
nvPhysicsWorld Class
Class Hierarchy
nvPhysicsWorld


nvShape Enumerations

nvShape Enumerations
nvPlaneShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvPlaneShape Class Members

nvPlaneShape Class Members
nvPlaneShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvPlaneShape Class
nvPlaneShape Members | The following tables list the members exposed by nvPlaneShape.
nvPlaneShape Methods | The methods of the nvPlaneShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvPlaneShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvPlaneShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvPlaneShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvPlaneShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvPlaneShape Class
nvPlaneShape Members | The following tables list the members exposed by nvPlaneShape.
nvPlaneShape Methods | The methods of the nvPlaneShape class are listed here.


Class Hierarchy

Class Hierarchy
nvPlaneShape Class
Class Hierarchy
nvShape
    nvPlaneShape


nvPrimitive Class Members

nvPrimitive Class Members
nvPrimitive Class
Members
Topics
nvPrimitive Members | The following tables list the members exposed by nvPrimitive.
nvPrimitive Methods | The methods of the nvPrimitive class are listed here.
nvPrimitive Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.


nvPrimitive Methods

nvPrimitive Methods
nvPrimitive Class
nvPrimitive Methods
GetBody | Returns associated shape.
GetData | Returns a pointer to the associated user defined data.
GetElasticity | Returns the elasticity coefficient of the primitive.
GetFriction | Returns the friction coefficient of the primitive.
GetLocalPosition | Returns the position of the primitive relatively to the body's coordinates.
GetLocalRotationMatrix | Returns a 3x3 rotation matrix relative to the body's coordinates.
GetShape | Returns containing body.
GetWorldPosition | Sets the position of the primitive relatively to the worlds coordinates.
GetWorldRotationMatrix | Returns a 3x3 rotation matrix relative to the world coordinates.
RotateAxisAngle | Used to set the rotation of the primitive relatively to the body's space.
SetData | As with bodies, each primitive can be associated with any user defined data pointer.
SetElasticity | Sets elasticity coefficient.
SetFriction | Sets friction coefficient.
SetLocalPosition | Sets the position of the primitive relatively to the body's coordinates.
SetLocalRotation | Sets the rotation matrix of the primitive relatively to the body's coordinates.


Topics

Topics
nvPrimitive Class
Topics
nvPrimitive Members | The following tables list the members exposed by nvPrimitive.
nvPrimitive Methods | The methods of the nvPrimitive class are listed here.


Class Hierarchy

Class Hierarchy
nvPrimitive Class
Class Hierarchy
nvPrimitive


nvShape Enumerations

nvShape Enumerations
nvShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvShape Class Members

nvShape Class Members
nvShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.


Class Hierarchy

Class Hierarchy
nvShape Class
Class Hierarchy
nvShape
    nvBoxShape
    nvConvexShape
    nvCylinderShape
    nvPlaneShape
    nvSphereShape
    nvTriMeshShape


nvShapeMngr Class Members

nvShapeMngr Class Members
nvShapeMngr Class
Members
Topics
nvShapeMngr Members | The following tables list the members exposed by nvShapeMngr.
nvShapeMngr Methods | The methods of the nvShapeMngr class are listed here.
nvShapeMngr Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.


nvShapeMngr Methods

nvShapeMngr Methods
nvShapeMngr Class
nvShapeMngr Methods
CreateBox | Create a box shape, given its dimentions.
CreateConvex | Create an empty convex shape.
CreateCylinder | Create a cylinder shape, given its radius and height.
CreatePlane |
CreateSphere | Create a sphere shape, given its radius.
CreateTriMesh | Create an empty triangle mesh shape.
DestroyShape | Destroys a shape, rarely used.


Topics

Topics
nvShapeMngr Class
Topics
nvShapeMngr Members | The following tables list the members exposed by nvShapeMngr.
nvShapeMngr Methods | The methods of the nvShapeMngr class are listed here.


Class Hierarchy

Class Hierarchy
nvShapeMngr Class
Class Hierarchy
nvShapeMngr


nvShape Enumerations

nvShape Enumerations
nvSphereShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvSphereShape Class Members

nvSphereShape Class Members
nvSphereShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvSphereShape Class
nvSphereShape Members | The following tables list the members exposed by nvSphereShape.
nvSphereShape Methods | The methods of the nvSphereShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvSphereShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvSphereShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvSphereShape Class
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetRadius | Return the Radius of the sphere shape.
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvSphereShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvSphereShape Class
nvSphereShape Members | The following tables list the members exposed by nvSphereShape.
nvSphereShape Methods | The methods of the nvSphereShape class are listed here.


Class Hierarchy

Class Hierarchy
nvSphereShape Class
Class Hierarchy
nvShape
    nvSphereShape


nvShape Enumerations

nvShape Enumerations
nvTriMeshShape Class
nvShape Enumerations
eShapeType
Enum specifying the shape class


nvTriMeshShape Class Members

nvTriMeshShape Class Members
nvTriMeshShape Class
Members
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvTriMeshShape Class
nvTriMeshShape Members | The following tables list the members exposed by nvTriMeshShape.
nvTriMeshShape Methods | The methods of the nvTriMeshShape class are listed here.
nvShape Enumerations
eShapeType
Enum specifying the shape class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvTriMeshShape Class
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


nvShape Methods

nvShape Methods
nvTriMeshShape Class
nvShape Methods
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.
nvTriMeshShape Class
AddTriangle | Adds a triangle to the triangle mesh.
Begin | Called before adding triangles.
End | Called after finishing adding triangles.
GetBoundingRadius | Return the radius of the shape's bounding sphere.
GetBoundingRadiusSqr | Return the square root of the radius of the shape's bounding sphere. :) What the heck?!
GetType | get the type before u cast Is this used at all?! Return an enumeration indicating the specific class of the shape.


Topics

Topics
nvTriMeshShape Class
Topics
nvShape Members | The following tables list the members exposed by nvShape.
nvShape Enumerations | The enumerations of the nvShape class are listed here.
nvShape Methods | The methods of the nvShape class are listed here.
nvTriMeshShape Class
nvTriMeshShape Members | The following tables list the members exposed by nvTriMeshShape.
nvTriMeshShape Methods | The methods of the nvTriMeshShape class are listed here.


Class Hierarchy

Class Hierarchy
nvTriMeshShape Class
Class Hierarchy
nvShape
    nvTriMeshShape


Contents

Contents
This is the table of contents of this documentation.
This is a first draft. If you have any questions or requests concerning the SDK or the documentation, please send them to info@ThePhysicsEngine.com.
Symbol Reference
Classes
nvBody Class
nvBody Members
nvBody Data Members
nvBody::Primitives Data Member
nvBody Methods
nvBody::AddBox Method
nvBody::AddConvex Method
nvBody::AddCylinder Method
nvBody::AddNewPrimitive Method
AddOneFrameForce Method
nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal)
nvBody::AddOneFrameForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
nvBody::AddOneFrameTorque Method
AddPermanentForce Method
nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal)
nvBody::AddPermanentForce Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
nvBody::AddPermanentTorque Method
AddPlane Method
nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal)
nvBody::AddPlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
nvBody::AddSphere Method
nvBody::AddTriMesh Method
nvBody::GetAngularVelocity Method
nvBody::GetCenterOfMass Method
nvBody::GetData Method
nvBody::GetLinearVelocity Method
nvBody::GetMass Method
nvBody::GetPositon Method
nvBody::GetRotationMatrix Method
nvBody::IsSleeping Method
nvBody::IsStatic Method
nvBody::Move Method
nvBody::RotateAxisAngle Method
nvBody::SetAngularVelocity Method
nvBody::SetData Method
nvBody::SetLinearVelocity Method
nvBody::SetPosition Method
nvBodyMngr Class
nvBodyMngr Members
nvBodyMngr Methods
nvBodyMngr::Create Method
nvBodyMngr::Destroy Method
nvBoxShape Class
nvBoxShape Members
nvBoxShape Methods
nvBoxShape::GetBoundingRadius Method
nvBoxShape::GetBoundingRadiusSqr Method
nvBoxShape::GetDimensions Method
nvBoxShape::GetType Method
nvCarWheelJoint Class
nvCarWheelJoint Members
nvCarWheelJoint Methods
nvCarWheelJoint::AddOneFrameTorque Method
nvCarWheelJoint::GetAngle Method
nvCarWheelJoint::GetVelocity Method
nvCarWheelJoint::SetMaxTorque Method
nvCarWheelJoint::SetRequiredVelocity Method
nvCarWheelJoint::SetSteeringAngle Method
nvConvexShape Class
nvConvexShape Members
nvConvexShape Methods
nvConvexShape::AddEdge Method
nvConvexShape::AddIndexedTriangleFan Method
nvConvexShape::AddIndexedTriangles Method
nvConvexShape::AddIndexedTriangleStrip Method
nvConvexShape::AddTriangle Method
nvConvexShape::AddTriangleFan Method
nvConvexShape::AddTriangles Method
nvConvexShape::AddTriangleStrip Method
nvConvexShape::AddVertices Method
nvConvexShape::Begin Method
nvConvexShape::End Method
nvConvexShape::GetBoundingRadius Method
nvConvexShape::GetBoundingRadiusSqr Method
nvConvexShape::GetType Method
nvCylinderShape Class
nvCylinderShape Members
nvCylinderShape Methods
nvCylinderShape::GetBoundingRadius Method
nvCylinderShape::GetBoundingRadiusSqr Method
nvCylinderShape::GetHeight Method
nvCylinderShape::GetRadius Method
nvCylinderShape::GetType Method
nvDoubleHingeJoint Class
nvDoubleHingeJoint Members
nvDoubleHingeJoint Methods
nvDoubleHingeJoint::AddOneFrameTorque1 Method
nvDoubleHingeJoint::AddOneFrameTorque2 Method
nvDoubleHingeJoint::SetMaxTorque1 Method
nvDoubleHingeJoint::SetMaxTorque2 Method
nvDoubleHingeJoint::SetRequiredVelocity1 Method
nvDoubleHingeJoint::SetRequiredVelocity2 Method
nvHingeJoint Class
nvHingeJoint Members
nvHingeJoint Methods
nvHingeJoint::AddOneFrameTorque Method
nvHingeJoint::GetAngle Method
nvHingeJoint::GetVelocity Method
nvHingeJoint::SetMaxTorque Method
nvHingeJoint::SetRequiredVelocity Method
nvJoint Class
nvJointMngr Class
nvJointMngr Members
nvJointMngr Methods
CreateBallJoint Method
nvJointMngr::CreateBallJoint Method (nvBody *, nvBody *, nvReal, nvReal, nvReal)
nvJointMngr::CreateBallJoint Method (nvBody *, nvReal, nvReal, nvReal, nvBody *, nvReal, nvReal, nvReal)
nvJointMngr::CreateCarWheelJoint Method
nvJointMngr::CreateDoubleHingeJoint Method
nvJointMngr::CreateFixedJoint Method
nvJointMngr::CreateHingeJoint Method
nvJointMngr::CreateLimitedBallJoint Method
nvJointMngr::CreateStiffSpringJoint Method
nvJointMngr::CreateUniversalJoint Method
nvJointMngr::DeleteAllBodyJoints Method
nvJointMngr::DestroyJoint Method
nvJointMngr::nvJointMngr::CreatePrismaticJoint Method
nvLimitedBallJoint Class
nvLimitedBallJoint Members
nvLimitedBallJoint Methods
nvLimitedBallJoint::GetAnchor Method
nvLimitedBallJoint::GetAngle Method
nvLimitedBallJoint::SetMaxLimit Method
nvLimitedBallJoint::SetMaxTorque Method
nvLimitedBallJoint::SetMinLimit Method
nvLimitedBallJoint::SetRequiredVelocity Method
nvPhysicsWorld Class
nvPhysicsWorld Members
nvPhysicsWorld Data Members
nvPhysicsWorld::BodyMngr Data Member
nvPhysicsWorld::JointMngr Data Member
nvPhysicsWorld::ShapeMngr Data Member
nvPhysicsWorld Methods
nvPhysicsWorld::GetNoOfSolvingIterations Method
nvPhysicsWorld::GetTimeStep Method
nvPhysicsWorld::Reset Method
RunStep Method
nvPhysicsWorld::RunStep Method (nvReal)
nvPhysicsWorld::RunStep Method (nvReal, nvReal, int)
nvPhysicsWorld::SetBroadPhase Method
nvPhysicsWorld::SetCFM Method
nvPhysicsWorld::SetCollisionNotify Method
nvPhysicsWorld::SetGravity Method
nvPhysicsWorld::SetNoOfSolvingIterations Method
nvPhysicsWorld::SetObjectsAutoDeactivation Method
nvPlaneShape Class
nvPlaneShape Members
nvPlaneShape Methods
nvPlaneShape::GetBoundingRadius Method
nvPlaneShape::GetBoundingRadiusSqr Method
nvPlaneShape::GetType Method
nvPrimitive Class
nvPrimitive Members
nvPrimitive Methods
nvPrimitive::GetBody Method
nvPrimitive::GetData Method
nvPrimitive::GetElasticity Method
nvPrimitive::GetFriction Method
nvPrimitive::GetLocalPosition Method
nvPrimitive::GetLocalRotationMatrix Method
nvPrimitive::GetShape Method
nvPrimitive::GetWorldPosition Method
nvPrimitive::GetWorldRotationMatrix Method
nvPrimitive::RotateAxisAngle Method
nvPrimitive::SetData Method
nvPrimitive::SetElasticity Method
nvPrimitive::SetFriction Method
nvPrimitive::SetLocalPosition Method
nvPrimitive::SetLocalRotation Method
nvShape Class
nvShape Members
nvShape Enumerations
nvShape::eShapeType Enumeration
nvShape Methods
nvShape::GetBoundingRadius Method
nvShape::GetBoundingRadiusSqr Method
nvShape::GetType Method
nvShapeMngr Class
nvShapeMngr Members
nvShapeMngr Methods
nvShapeMngr::CreateBox Method
nvShapeMngr::CreateConvex Method
nvShapeMngr::CreateCylinder Method
CreatePlane Method
nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal)
nvShapeMngr::CreatePlane Method (nvReal, nvReal, nvReal, nvReal, nvReal, nvReal)
nvShapeMngr::CreateSphere Method
nvShapeMngr::CreateTriMesh Method
nvShapeMngr::DestroyShape Method
nvSphereShape Class
nvSphereShape Members
nvSphereShape Methods
nvSphereShape::GetBoundingRadius Method
nvSphereShape::GetBoundingRadiusSqr Method
nvSphereShape::GetRadius Method
nvSphereShape::GetType Method
nvTriMeshShape Class
nvTriMeshShape Members
nvTriMeshShape Methods
nvTriMeshShape::AddTriangle Method
nvTriMeshShape::Begin Method
nvTriMeshShape::End Method
nvTriMeshShape::GetBoundingRadius Method
nvTriMeshShape::GetBoundingRadiusSqr Method
nvTriMeshShape::GetType Method
Structs, Records, Enums
eBroadPhaseModes Enumeration
Types
CollisionNotifyBackFnc Type
nvReal Type


Index

Index
These are all topics and symbols available in this documentation.
C | E | N | S | T
C
Classes
CollisionNotifyBackFnc type
E
eBroadPhaseModes enumeration
N
nvBody class
about nvBody class
AddOneFrameForce method
AddPermanentForce method
AddPlane method
nvBody data members
nvBody members
nvBody methods
nvBody::AddBox method
nvBody::AddConvex method
nvBody::AddCylinder method
nvBody::AddNewPrimitive method
nvBody::AddOneFrameForce method
nvBody::AddOneFrameTorque method
nvBody::AddPermanentForce method
nvBody::AddPermanentTorque method
nvBody::AddPlane method
nvBody::AddSphere method
nvBody::AddTriMesh method
nvBody::GetAngularVelocity method
nvBody::GetCenterOfMass method
nvBody::GetData method
nvBody::GetLinearVelocity method
nvBody::GetMass method
nvBody::GetPositon method
nvBody::GetRotationMatrix method
nvBody::IsSleeping method
nvBody::IsStatic method
nvBody::Move method
nvBody::Primitives data member
nvBody::RotateAxisAngle method
nvBody::SetAngularVelocity method
nvBody::SetData method
nvBody::SetLinearVelocity method
nvBody::SetPosition method
nvBodyMngr class
about nvBodyMngr class
nvBodyMngr members
nvBodyMngr methods
nvBodyMngr::Create method
nvBodyMngr::Destroy method
nvBoxShape class
about nvBoxShape class
nvBoxShape members
nvBoxShape methods
nvBoxShape::GetBoundingRadius method
nvBoxShape::GetBoundingRadiusSqr method
nvBoxShape::GetDimensions method
nvBoxShape::GetType method
nvCarWheelJoint class
about nvCarWheelJoint class
nvCarWheelJoint members
nvCarWheelJoint methods
nvCarWheelJoint::AddOneFrameTorque method
nvCarWheelJoint::GetAngle method
nvCarWheelJoint::GetVelocity method
nvCarWheelJoint::SetMaxTorque method
nvCarWheelJoint::SetRequiredVelocity method
nvCarWheelJoint::SetSteeringAngle method
nvConvexShape class
about nvConvexShape class
nvConvexShape members
nvConvexShape methods
nvConvexShape::AddEdge method
nvConvexShape::AddIndexedTriangleFan method
nvConvexShape::AddIndexedTriangles method
nvConvexShape::AddIndexedTriangleStrip method
nvConvexShape::AddTriangle method
nvConvexShape::AddTriangleFan method
nvConvexShape::AddTriangles method
nvConvexShape::AddTriangleStrip method
nvConvexShape::AddVertices method
nvConvexShape::Begin method
nvConvexShape::End method
nvConvexShape::GetBoundingRadius method
nvConvexShape::GetBoundingRadiusSqr method
nvConvexShape::GetType method
nvCylinderShape class
about nvCylinderShape class
nvCylinderShape members
nvCylinderShape methods
nvCylinderShape::GetBoundingRadius method
nvCylinderShape::GetBoundingRadiusSqr method
nvCylinderShape::GetHeight method
nvCylinderShape::GetRadius method
nvCylinderShape::GetType method
nvDoubleHingeJoint class
about nvDoubleHingeJoint class
nvDoubleHingeJoint members
nvDoubleHingeJoint methods
nvDoubleHingeJoint::AddOneFrameTorque1 method
nvDoubleHingeJoint::AddOneFrameTorque2 method
nvDoubleHingeJoint::SetMaxTorque1 method
nvDoubleHingeJoint::SetMaxTorque2 method
nvDoubleHingeJoint::SetRequiredVelocity1 method
nvDoubleHingeJoint::SetRequiredVelocity2 method
nvHingeJoint class
about nvHingeJoint class
nvHingeJoint members
nvHingeJoint methods
nvHingeJoint::AddOneFrameTorque method
nvHingeJoint::GetAngle method
nvHingeJoint::GetVelocity method
nvHingeJoint::SetMaxTorque method
nvHingeJoint::SetRequiredVelocity method
nvJoint class
about nvJoint class
nvJointMngr class
about nvJointMngr class
CreateBallJoint method
nvJointMngr class
nvJointMngr members
nvJointMngr methods
nvJointMngr::CreateBallJoint method
nvJointMngr::CreateCarWheelJoint method
nvJointMngr::CreateDoubleHingeJoint method
nvJointMngr::CreateFixedJoint method
nvJointMngr::CreateHingeJoint method
nvJointMngr::CreateLimitedBallJoint method
nvJointMngr::CreateStiffSpringJoint method
nvJointMngr::CreateUniversalJoint method
nvJointMngr::DeleteAllBodyJoints method
nvJointMngr::DestroyJoint method
nvJointMngr::nvJointMngr::CreatePrismaticJoint method
nvLimitedBallJoint class
about nvLimitedBallJoint class
nvLimitedBallJoint members
nvLimitedBallJoint methods
nvLimitedBallJoint::GetAnchor method
nvLimitedBallJoint::GetAngle method
nvLimitedBallJoint::SetMaxLimit method
nvLimitedBallJoint::SetMaxTorque method
nvLimitedBallJoint::SetMinLimit method
nvLimitedBallJoint::SetRequiredVelocity method
nvPhysicsWorld class
about nvPhysicsWorld class
nvPhysicsWorld data members
nvPhysicsWorld members
nvPhysicsWorld methods
RunStep method
nvPhysicsWorld::BodyMngr data member
nvPhysicsWorld::GetNoOfSolvingIterations method
nvPhysicsWorld::GetTimeStep method
nvPhysicsWorld::JointMngr data member
nvPhysicsWorld::Reset method
nvPhysicsWorld::RunStep method
nvPhysicsWorld::SetBroadPhase method
nvPhysicsWorld::SetCFM method
nvPhysicsWorld::SetCollisionNotify method
nvPhysicsWorld::SetGravity method
nvPhysicsWorld::SetNoOfSolvingIterations method
nvPhysicsWorld::SetObjectsAutoDeactivation method
nvPhysicsWorld::ShapeMngr data member
nvPlaneShape class
about nvPlaneShape class
nvPlaneShape members
nvPlaneShape methods
nvPlaneShape::GetBoundingRadius method
nvPlaneShape::GetBoundingRadiusSqr method
nvPlaneShape::GetType method
nvPrimitive class
about nvPrimitive class
nvPrimitive members
nvPrimitive methods
nvPrimitive::GetBody method
nvPrimitive::GetData method
nvPrimitive::GetElasticity method
nvPrimitive::GetFriction method
nvPrimitive::GetLocalPosition method
nvPrimitive::GetLocalRotationMatrix method
nvPrimitive::GetShape method
nvPrimitive::GetWorldPosition method
nvPrimitive::GetWorldRotationMatrix method
nvPrimitive::RotateAxisAngle method
nvPrimitive::SetData method
nvPrimitive::SetElasticity method
nvPrimitive::SetFriction method
nvPrimitive::SetLocalPosition method
nvPrimitive::SetLocalRotation method
nvReal type
nvShape class
about nvShape class
nvShape enumerations
nvShape members
nvShape methods
nvShape::eShapeType enumeration
nvShape::GetBoundingRadius method
nvShape::GetBoundingRadiusSqr method
nvShape::GetType method
nvShapeMngr class
about nvShapeMngr class
CreatePlane method
nvShapeMngr members
nvShapeMngr methods
nvShapeMngr::CreateBox method
nvShapeMngr::CreateConvex method
nvShapeMngr::CreateCylinder method
nvShapeMngr::CreatePlane method
nvShapeMngr::CreateSphere method
nvShapeMngr::CreateTriMesh method
nvShapeMngr::DestroyShape method
nvSphereShape class
about nvSphereShape class
nvSphereShape members
nvSphereShape methods
nvSphereShape::GetBoundingRadius method
nvSphereShape::GetBoundingRadiusSqr method
nvSphereShape::GetRadius method
nvSphereShape::GetType method
nvTriMeshShape class
about nvTriMeshShape class
nvTriMeshShape members
nvTriMeshShape methods
nvTriMeshShape::AddTriangle method
nvTriMeshShape::Begin method
nvTriMeshShape::End method
nvTriMeshShape::GetBoundingRadius method
nvTriMeshShape::GetBoundingRadiusSqr method
nvTriMeshShape::GetType method
S
Structs, Records, Enums
T
This is a first draft. If you have any questions or requests concerning the SDK or the documentation, please send them to info@ThePhysicsEngine.com.
Types


Welcome

Welcome to the nV Physics SDK.